Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Audio is not a valid Win32 Application?


  • Please log in to reply
No replies to this topic

#1 Legger

Legger

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:25 AM

Posted 20 August 2010 - 08:11 PM

My sound suddenly was off for some reason when a booted my computer. I noticed 2 things right away the sound icon on the taskbar said "The Audio service is not running" and when i try to right click it "Open Volume Mixer" is greyed out. I then google my problems and tried countless steps to fix this. I tried reinstalling my drivers and even system restore but nothing. I went to the Services menu and tried to start Windows Audio but it couldn't let me because of an error stating "Windows could not start the Windows Audio service on Local Computer Error 0x800700c1: 0x800700c1" I checked the Services menu and all the dependencies of Windows Audio was running and on automatic like most sites stated so i don't know why it didn't start. I scanned my computer for viruses but nothing. Finally i came across someone saying to check with event viewer so i did i saw "The Windows Audio service terminated with the following error: Windows Audio is not a valid Win32 application". I researched nonvalid Win32 applications and out of the reasons from viruses and not being in the right file, I thought the reason of being corrupted would be it. So i went and download the audiosrv.dlll file off a webiste that i scanned but i can't manage to replace the file or at least move it because i need permission to perform these action. Yet again more surfing but people said i need to run as administrator but when i right click it doesn't show plus i am already logged on admin.

Im using Windows Home Preiuem. Tell me if i am doing the right thing or not? If not some help please. Thanks!

Edited by Legger, 20 August 2010 - 08:23 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users