Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless Laptop Connection for Computer


  • Please log in to reply
11 replies to this topic

#1 noxzhu

noxzhu

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 20 August 2010 - 01:06 AM

Is there any way for a computer without a wireless adapter to connect to the internet through a laptop which is accessing a wireless network?

BC AdBot (Login to Remove)

 


#2 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:02:36 PM

Posted 20 August 2010 - 09:35 AM

Yes.

Oh, you want to know how as well ? Okay. The key is Internet Connection Sharing. Turn it on on the laptop and set it to share the Wireless connection. Then plug an Ethernet cable between the desktop and laptop Ethernet connectors. You may need a crossover cable if both units are old enough to not have Auto-MDX on their ports. Make sure you turn it off if you ever take the laptop out of the house. Connecting both the wired and wireless ports to the same network with ICS turned on causes serious weirdness to occur on the network and admins will be running around with their thwackysticks looking for someone, you in this case, to whomp on.

The Official Microsoft fully detailed instructions are here, just replace "dial-up" with "wireless" in your case.

#3 noxzhu

noxzhu
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 21 August 2010 - 12:49 AM

Thank you very much. I'll try it out as soon as I can and let you know if any problems come up. Thanks again!

Edit: Actually, quick question: Are there any effects on speed using this method for the client computer? How is bandwidth shared between the host and the client?

Edited by noxzhu, 21 August 2010 - 12:52 AM.


#4 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:05:36 PM

Posted 21 August 2010 - 09:50 AM

Edit: Actually, quick question: Are there any effects on speed using this method for the client computer? How is bandwidth shared between the host and the client?

It'll be sharing the total download speed(and upload) that the laptop is receiving. Should work just like cable/DSL modems/routers. Of course it takes more work, because alot of times firewalls don't like to play nicely when sharing the connection.

#5 noxzhu

noxzhu
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 21 August 2010 - 11:19 AM

I have a few questions on the setup. According to the Microsoft site, to set up the host computer I first right click and go into the properties of the network adapter I use to connect to the internet. Under the Sharing Tab, I check the box for allowing other network users to connect to the internet.

However, I also have a dropdown box under a label that says "Home networking connection:" which prompts me to select a private network connection from the network adapters excluding the one whose properties I'm changing. I'm confused as to what this does and what I should select.

I'm hoping to set it up as follows:

Modem -> Router with WiFi Support ---(wifi)---> Laptop ---(wire)---> Computer

Edit: It gives me an error and refuses to save changes no matter which home networking connection I select. I cannot save the changes for Internet Connection Sharing without selecting one either.

Edited by noxzhu, 21 August 2010 - 03:28 PM.


#6 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:02:36 PM

Posted 21 August 2010 - 10:50 PM

In this case you would be setting up sharing to share the wireless connection, and your "home network" connection would be your wired Ethernet (usually Ethernet 0). What error are you getting ?

#7 noxzhu

noxzhu
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 22 August 2010 - 12:58 PM

Screenshot: http://img72.imageshack.us/img72/2559/errorgc.jpg
In the screenshot, those are the properties of the wireless network adapter, which I use to connect to the router.

Edit: It may be because I didn't connect the laptop and the computer yet. Must you do so before you try to enable ICS?

Edited by noxzhu, 22 August 2010 - 12:59 PM.


#8 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:05:36 PM

Posted 22 August 2010 - 08:57 PM

I've never done ICS with Vista/7, but try connecting the two computers together and see what happens.

#9 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:02:36 PM

Posted 23 August 2010 - 09:44 AM

Nox, you will have to connect the cable first because the Ethernet port is not considered active or available until it sees a link. Once you have it configured it should remain even if the cable is temporarily disconnected.

#10 noxzhu

noxzhu
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 04 September 2010 - 12:23 PM

Okay, thank you; that makes sense, but how do I connect them? I don't suppose you simply connect the two computers directly with an ethernet cable (I just tried it and it isn't working, though it may just be that the ethernet cable is messed up, if this is indeed how you do it.) I'm still receiving the same error when setting up my ICS when I press okay.

My current setup is something like this:

Modem --(wire)--> Router w/ WiFi Support --(wifi)--> Laptop --(ethernet cable)--> Computer Which I Need to Get Internet On

Edit: I'm still somewhat unsure on what to select in the Home Networking Connection drop box shown in my earlier screenshot. I tried disabling my other two network adapters, and the sharing tab for my wireless connection's properties disappeared completely.

My laptop will be using the Wireless Networking Adapter to connect to the router for internet, which it will give to the computer via wire. At least, this is what I'm trying to get. I tried enabling ICS on the local area network adapter (and it required that my IP be static and xxx.xxx.xxx.1, which ended up giving me an ip conflict and removing this computer from the internet despite the fact that there were no other computers using our network; unless someone managed to crack our password which we changed once during the 3 months we've had it)

Edited by noxzhu, 04 September 2010 - 12:36 PM.


#11 noxzhu

noxzhu
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:01:36 PM

Posted 08 September 2010 - 09:38 PM

Does anyone have any suggestions?

As stated above, I'm not even sure if simply directly connecting my laptop to the computer with an ethernet cable will allow ICS to work properly.

Which network adapter do I go into the properties and enable ICS in?

Edit: After disabling the local arena network adapter, it no longer displays the home network drop box. However, I'm still receiving the ambiguous error when I attempt to check the ICS box and click okay.

Edit: As I was trying a few more things, the sharing tab in the network adapter properties simply disappeared and has not reappeared after a restart.

Edit Again: I got the sharing tab back by re-enabling a local area network adapter. I have tried enabling ICS with and without a static IP on my wifi adapter, and both have yielded the same ambiguous error.

Edit Again Again: Okay, I made some progress, and I managed to connect the two computers. (My second computer which is connecting through my laptop does indeed show that it is connected; the network adapter realizes it is connected to the other computer.) However, even though I connected the two, my second computer is unable to connect to the internet and my laptop cannot connect to the internet at all while ICS is enabled, whether it's plugged in to the other computer or not.

Edited by noxzhu, 08 September 2010 - 10:35 PM.


#12 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:02:36 PM

Posted 12 September 2010 - 10:42 PM

Hi Nox, sorry it took so long to get back to you, been out of town.

You are close. It may be that the laptop and desktop do not support Auto-MDIX on their Ethernet ports (that feature allows them to automatically correct the "polarity" of an Ethernet cable). If that is the case you will need what is known as a crossover ethernet cable. A normal cable is straight-through wired with the important pins being 1,2 and 3,6 (if you hold the RJ45 jack with the "tooth" downward, pin 1 is on the left and should be white/orange stripe or white/green stripe). A Crossover cable will have white/orange then solid orange on the left on one end and white/green and solid green on the left on the other end. You should be able to find a crossover cable at most office supply or computer shops. You should see the Ethernet as connected once the cable is plugged in.

It sounds like ICS is using a router setup rather than bridge (I haven't used it since XP), so the IP address they are talking about needs to be in a different subnet than your existing router. So, if your router is 192.168.1.1 your laptop IP on the wired port needs to be something like 192.168.2.1 and the address on your desktop (which it may get automatically, or maybe not) would be 192.168.2.x where X is between 2 and 254 with a gateway of 192.168.2.1 and DNS of 192.168.1.1 in all likelihood. The IP address on the Wireless port of your laptop should be left to get an IP address automatically.

In the dialog box you screenshot the Ethernet port is the correct answer.

This should clear things up. You should end up with:
Modem --(wire)--> Router w/ WiFi Support --(wifi)--> Laptop --(ethernet cable)--> Computer
192.168.1.1 (wls) 192.168.1.x / (En) 192.168.2.1 192.168.2.x




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users