Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can only PING in one direction


  • Please log in to reply
10 replies to this topic

#1 Just Trying My Best

Just Trying My Best

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:44 AM

Posted 08 August 2010 - 04:28 PM

Both of my PC's are behind a Linksys Router (BEFSR41). I can ping PC1 from PC2 but not the other way. Any ideas?
Danno

PC--Lenovo ThinkCentre M52, Processor--Pentium 4 3.00GHz, Memory--512MB DDR-2, MB--IBM with Intel I945P/PL/G/GZ Chipset
Drive--WD800JD-08LSA0 Sata, Video--Intel 82945G OnBoard, Network--Bell Wireless DSL Modem/Router
OS--Windows XP Professional SP3, Browser--IE 8, Email--Outlook 2002 SP3, Anti-Virus--Bell Internet Secturity Service

BC AdBot (Login to Remove)

 


#2 Wizho

Wizho

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:02:44 AM

Posted 09 August 2010 - 01:32 PM

PC2 might be blocking incoming ICMP packets (pings), you should check your firewall configuration.

#3 Just Trying My Best

Just Trying My Best
  • Topic Starter

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:44 AM

Posted 10 August 2010 - 11:25 AM

Thanks for you input!

I check the settings in Windows Firewall on both PCs. Under the ICMP settings, the first option (Allow incoming echo requests) is checked off. This should allow pings to be processed.
Danno

PC--Lenovo ThinkCentre M52, Processor--Pentium 4 3.00GHz, Memory--512MB DDR-2, MB--IBM with Intel I945P/PL/G/GZ Chipset
Drive--WD800JD-08LSA0 Sata, Video--Intel 82945G OnBoard, Network--Bell Wireless DSL Modem/Router
OS--Windows XP Professional SP3, Browser--IE 8, Email--Outlook 2002 SP3, Anti-Virus--Bell Internet Secturity Service

#4 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:03:44 AM

Posted 11 August 2010 - 09:19 AM

Do you have any firewalls installed? Some anti-virus software come with firewalls built into them.

#5 Just Trying My Best

Just Trying My Best
  • Topic Starter

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:44 AM

Posted 11 August 2010 - 04:17 PM

Hi NpaMA,

Thanks for your reply.

I am running Comodo Internet Security Premium on both machines. This is both a firewall and anti-virus program. Same on both!
Danno

PC--Lenovo ThinkCentre M52, Processor--Pentium 4 3.00GHz, Memory--512MB DDR-2, MB--IBM with Intel I945P/PL/G/GZ Chipset
Drive--WD800JD-08LSA0 Sata, Video--Intel 82945G OnBoard, Network--Bell Wireless DSL Modem/Router
OS--Windows XP Professional SP3, Browser--IE 8, Email--Outlook 2002 SP3, Anti-Virus--Bell Internet Secturity Service

#6 Synetech

Synetech

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:03:44 AM

Posted 11 August 2010 - 04:37 PM

Iím guessing that the IP for PC1 is lower than that for PC2 (eg 192.168.0.2 < 192.168.0.3). Check your routerís firewall settings. You may have a firewall rule that blocks ICMP to one IP address, especially since default rules are often just guides, they will usually only apply to a single address instead of a range.
****** *** ****** * ****; * ***** **** ** *** **** ******* *** ****** ************ ****.

-- Synetech

#7 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:03:44 AM

Posted 12 August 2010 - 07:21 PM

Hi NpaMA,

Thanks for your reply.

I am running Comodo Internet Security Premium on both machines. This is both a firewall and anti-virus program. Same on both!

It's probably something inside of Comodo causing the problem, can you temporary disable your virus protection and firewalls to try it? If the same problem occurs, then check your router settings as suggested above.

#8 Synetech

Synetech

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:03:44 AM

Posted 12 August 2010 - 08:06 PM

The OP said that both systems are running Comodo, but I guess the settings on PC2 could have been changed to block them, (then again, most personal firewalls Iíve seen in years have ICMP packets disabled by default, so it would mean that PC1ís firewall was altered to allow ICMP packets either intentionally or notÖ)
****** *** ****** * ****; * ***** **** ** *** **** ******* *** ****** ************ ****.

-- Synetech

#9 Just Trying My Best

Just Trying My Best
  • Topic Starter

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:44 AM

Posted 13 August 2010 - 01:12 PM

NpaMA and Syntech,

Thank you both for your input. Even with Windows Firewall disabled on both, and Comodo AV/Firewall shut down on both, I can still only ping one way.

The big issue here is that the USB printer is connected to the PC that I can't Ping. I can see the the other PC in My Network Places but I can not see the the Printer, which is a 'shared' printer, and I can not access any folders that are set up as shares. I just get the message:

" share is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The Network path was not found."

I have an administrator account on that PC (same login as on mine).

As far as the firewall settings on my Lynksys, I don't know exactly where to look in there. Any help with that would be great.
Danno

PC--Lenovo ThinkCentre M52, Processor--Pentium 4 3.00GHz, Memory--512MB DDR-2, MB--IBM with Intel I945P/PL/G/GZ Chipset
Drive--WD800JD-08LSA0 Sata, Video--Intel 82945G OnBoard, Network--Bell Wireless DSL Modem/Router
OS--Windows XP Professional SP3, Browser--IE 8, Email--Outlook 2002 SP3, Anti-Virus--Bell Internet Secturity Service

#10 Synetech

Synetech

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:03:44 AM

Posted 13 August 2010 - 02:47 PM

Open a web browser and navigate to 192.168.0.1. That is the standard router IP address (though yours may be different, in which case you have to either remember what you set it to, or more likely, refer to the manual).

In the router configuration page you should find a page about firewalls or something to that effect, where you can check the rules (ICMP is often blocked).
****** *** ****** * ****; * ***** **** ** *** **** ******* *** ****** ************ ****.

-- Synetech

#11 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:03:44 AM

Posted 14 August 2010 - 09:00 PM

Open a web browser and navigate to 192.168.0.1. That is the standard router IP address (though yours may be different, in which case you have to either remember what you set it to, or more likely, refer to the manual).

In the router configuration page you should find a page about firewalls or something to that effect, where you can check the rules (ICMP is often blocked).

Linksys default is 192.168.1.1 or click: http://192.168.1.1/




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users