Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Only one program will open


  • Please log in to reply
2 replies to this topic

#1 PaulMcKeown

PaulMcKeown

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:45 PM

Posted 29 July 2010 - 02:36 AM

This is an "All of a sudden outta the blue" problem. A couple of days ago I booted up and no matter what I tried to open, the only program that would open was ToniArts EasyCleaner. This is a free utility with a variety of useful toos I've had on my PC for a year or so (never had a problem with it). I had not used it for a while, and was not using it when the problem appeared. EasyCleaner whould also open when I selecter anything in 'Control Panel' or attempted a 'Run' command. The work-around has been to open Explorer, navigate to the programs .exe, right click and select 'Run As'. I was still not able to use any R8un commands or open anything in 'Control Panel' but was able to find and delete every instance of EasyCleaner.
BAAAD IDEA.
I can still use the work around, but now instead of opening a program when I select something off the 'Start' menu, the 'Open With' dialog box appears. If I attempt to open something in 'Control Panel' I get the following message- C\WINDOWS\system32\rundll.exe Application not found. It is rite where it's supposed to be, in 'system32'.
My AV is Kaspersky internet Security 2010 and it gave no indication that something was amiss. I made sure it was up to date and ran a full scan and still nothing.
Any suggestions as to what has happened here and how to fix???
Thanks kindly
Paul

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,252 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:45 PM

Posted 29 July 2010 - 07:36 AM

"ToniArts may not be held accountable in any way if EasyCleaner affects your computer in a negative way."

Taken from http://personal.inet.fi/business/toniarts/ecleane.htm.

I would suggest a clean install, based on that statement...there's no telling what has happened with such a program installed.

Louis

#3 boethe

boethe

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:10:45 PM

Posted 29 July 2010 - 07:58 AM

The short answer is that your registry is corrupted. The registry is what links exe files to the proper rundll, that is basically when you click a exe file is passes the exe file as a parameter to a rundll program much like you would pass a mp3 file to a music program. That has clearly been corrupted in your case.

There are tools for correcting the exe associations in the registry but because the registry is such a sensitive matter I don't give direct advice on messing the registry since I am a new member here.

As hamluis said a complete clean reinstall would be the simplest way to go. I recommend you figure out what files you need to save and start backing up to a UBS drive or something. Once you have everything you need backed up and are not risking data you might want to play with the registry to see if you can fix it without a re-install but again I think hamluis point is that even if you fix the registry who knows what else ToniArts has done and you probably wont find anyone here who is an expert in uninstalling ToniArts software.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users