Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Explorer.exe Disables TaskMgr, Regedit and possibly safemode


  • Please log in to reply
1 reply to this topic

#1 deadeyezzz

deadeyezzz

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:18 AM

Posted 23 July 2010 - 11:32 AM

Good Day,

This is my first post in this forum and I hope someone can help me.

My system's OS is WinXP Pro SP3 and my problem is that my systems TaskMgr and Regedit keeps getting disabled.
Here's the Troubleshooting steps that i have done so far;


1. Ran Superantispyware, Malwarebytes and Avast but none of them has detected any infection.

2. Ran a .vbs file that re-enables both Taskmgr and Regedit but no go. It just enables the taskmgr and Regedit for 5 secs then it is disabled again.
Note: One thing I've notice is that if you try manually delete the DisableTaskmgr and DisableRegistryTools, the DWORD enrties will be back there after
5 or so seconds.

3. I disabled all startup items and non-windows services using msconfig, no go.

4. I tried booting to safemode to check the issue will happen there but it seems that it is disabled too since the system just restarts when trying to boot to safe.

5. I ran ProcessMonitor and then ran the .vbs fix again. The ProcessMonitor was able to detect that Explorer.exe is changing the DWORD of both Taskmgr and
Regedit.
Note: Aside from Explorer.exe, the ProcessMonitor also detects the ctfmon.exe and winmine.exe as the culprit.

6. Ran autoruns program to try disabling the program but I can't seem to find it there.

7. I tried to manually delete those items but no go. In fact when I deleted the explorer.exe, I lost my icons and taskbar.

Explorer.exe seems to be a legit process and somehow something is using it to disable Taskmgr and Regedit. Aside from those two (2) windows tools it disable
firewall alerts aswell among other stuff.

I hope someone it this forum can help me in resolving this problem. Thank you in advance!

BC AdBot (Login to Remove)

 


#2 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 36,949 posts
  • ONLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:07:18 PM

Posted 24 July 2010 - 12:54 AM

Hello,

Please follow the instructions in ==>This Guide<== starting at Step 6.

Once the proper logs are created, then make a NEW TOPIC and post it ==>HERE<== Please include a description of your computer issues and what you have done to resolve them.

If you can produce at least some of the logs, then please create the new topic and explain what happens when you try to create the log(s) that you couldn't get. If you cannot produce any of the logs, then still post the topic and explain that you followed the Prep. Guide, were unable to create the logs, and describe what happens when you try to create the logs.

Orange Blossom :thumbsup:
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users