Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


numlock turning off

  • Please log in to reply
1 reply to this topic

#1 ruggb


  • Members
  • 33 posts
  • Local time:04:31 PM

Posted 21 July 2010 - 05:24 PM

when I start the puter the numlock comes on.
part way thry the startup screen it goes off.

How to set it on.

BIOS is set for it to be on - something in XP is turning it off.


BC AdBot (Login to Remove)


#2 joseibarra


  • Members
  • 1,304 posts
  • Gender:Male
  • Location:Downstairs
  • Local time:03:31 PM

Posted 21 July 2010 - 08:22 PM

I made some notes when I tried to 'splain this num lock/BIOS thing to somebody once before - maybe the will help you get going.

Set the keyboard indicators the way you want and logoff. If you set them and you logoff, XP should remember that the next time you login and every user could be different (or at the XP default).

There may not be a way to set it in every BIOS. The BIOS settings will get overridden first by XP when the system boots, then by the user profile when it the user logs in. The XP default is all indicators off.

Let's say you could not change it in the BIOS - what would you do?

XP remembers (possibly changes) the setting when a user logs off or the system is shutdown and applies it again when the user logs in. Now you know one thing that is happening when XP says "Saving your settings...".

This is why the BIOS setting may appear "not to work" or the keys seem to keep changing. They are behaving as designed.

You will have the same settings when you login that you had when you logged out or shutdown.

If you need to have the Num Lock key on before you login change the Windows default. Read this article:


Each user has their own setting in their profile.

You can adjust the default setting for each newly created user profile or for an individual profile by adjusting the value of:


For the current user the location for InitialKeyboardIndicators is:


Here are all the values for InitialKeyboardIndicators:

* 0 - all indicators off
* 1 - Caps Lock on
* 2 - Num Lock on
* 4 - Scroll Lock on

Or, combine them by adding the values to some other number:

* 3 - Caps Lock and Num Lock on
* 5 - Caps Lock and Scroll Lock on
* 6 - Num Lock and Scroll Lock on
* 7 - Caps Lock, Num Lock, and Scroll Lock on

For all (new) users, the location for InitialKeyboardIndicators is:


If the InitialKeyboardIndicators key does not exist, create it.

Edited by joseibarra, 21 July 2010 - 08:23 PM.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users