Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing or corrupted DxSetup.exe


  • Please log in to reply
1 reply to this topic

#1 curlysue-tew

curlysue-tew

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:44 AM

Posted 21 July 2010 - 03:15 PM

I have a Missing or corrupted DxSetup.exe problem...

Posted Image

...and I recall seeing this same error message once, perhaps twice in the 2 or 3 months. :thumbsup:

This same DxSetup.exe error message occurred when I was attempting to install non-essential software programs. And when the (above) error message window popped up, I chose to terminate the installation and delete the non-essential software program.

Currently, this DxSetup.exe error message occurs when I try to install Intel's Network Adapter Drivers 15.4.1 for Windows XP.

Back on 2010 April 29, I successfully installed Intel's Network Adapter Drivers 15.2 for Windows XP, and did not have any problems - in other words, I did not experience this DxSetup.exe error message.

My operating system is Windows XP SP3, 32-bit, up to date via Windows Update, with the exception of Microsoft's Malicious Removal Tools, and Internet Explorer 7 or 8. I have never allowed Windows Update to install any Malicious Removal Tool, and because I only use Internet Explorer for Windows Updates (my primary browser is Firefox 3.6 including its latest version and updates), I find no value nor interest to upgrade to Internet Explorer 7 or 8.

According to Add or Remove Programs, I have the following Microsoft .NET Frameworks installed...

1.1 - v1.1.4322
2.0 Service Pack 2 - v2.0.50727
3.0 Service Pack 2
3.5 Service Pack 1

...which is confirmed by ASoft .NET Version Detector 2007 as follows:

Posted Image

Upon reviewing the respective install LOG files...

Posted Image

...I found no apparent error messages.

The file dd_dotnetfx3error.txt is empty - and searching for the word "error" in the dd_dotnetfx3install.txt file, produces only one reference...

[04/25/09,00:23:40] Microsoft .NET Framework 3.0: CRootComponent::Install(): MSIInstallProduct returned ERROR_SUCCESS.

The file dd_dotnetfx35error.txt is empty - and searching for the word "error" in the dd_dotnetfx35install.txt file, produces the following references...

[04/25/09,17:09:22] Setup.exe: GetGlobalCustomProperty - Property: {481CEF9F-033A-11D3-ACE2-00C04F8EEBA1} - PropertyName: Disable Error Logging - Value: 0

[04/25/09,17:30:43] Microsoft .NET Framework 3.5: CRootComponent::Install(): MSIInstallProduct returned ERROR_SUCCESS.

[04/25/09,17:31:08] Setup.exe: GetGlobalCustomProperty - Property: {481CEF9F-033A-11D3-ACE2-00C04F8EEBA1} - PropertyName: Disable Error Logging - Value: 0

[04/25/09,20:04:39] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): Error code 0 for this component means "Baseline succeeded. No further action required."

[04/25/09,20:06:46] XPSEPSC Installer: Error code 3010 for this component means "Baseline succeeded. Reboot required to complete setup action."

[04/25/09,20:08:14] Microsoft .NET Framework 3.5 SP1: CRootComponent::Install(): MSIInstallProduct returned ERROR_SUCCESS.

To ensure my Registry is not effected by any new program installation, I typically back it up prior to the install. However, because I install or updated software several times each week, once the new or updated program appears to work as described, I generally delete the Registry backup file. This may seem severe, but once I install a new program or update, the previous Registry backup become moot. Moot because it has no value since restoring it also removes any newer Registry entries, updates, etc.

I am running Windows Installer 4.5 and have not experienced any problems with it.

I manually update Windows XP by visiting the Windows Update website once a week, and utilize the CUSTOM option to check for Windows XP updates.

For non-Windows operating system software, I visit other websites like MajorGeeks and FileHippo. I try to download new software direct from the author's website(s) whenever possible.

When available, I generally update my DirectX files. Recently, I installed DirectX June 2010 Redistributable (with filename directx_Jun2010_redist.exe). As with all previous versions, I extracted this file a temp directory, F:\DirectX_Install. Once extracted, I executed DXSETUP.EXE to install the DirectX update. Once complete, I typically leave the Application, Application Extensions and Cabinet Files, in place until the next DirectX Redistributable is released - and when it is, I delete all files in F:\DirectX_Install before executing the new DXSETUP.EXE application file.

While I have executed the DirectX Redistributable DXSETUP.EXE application file several time in the last 2 to 3 years (concurrent with the respective DirectX Redistributable release), I have never looked for the DxSetup.exe file elsewhere on my HDD. Therefore, I have no idea where it is supposed to be located. I read one (confusing website's) expert suggest that it is located in the C:\WINDOWS\System32 directory. When I looked, it was not there - so I copied the latest DXSETUP.EXE file to it. Unfortunately, it did not correct or resolve the problem - the problem remains.

I am running DirectX 9.0c, and ran the DirectX Diagnostic Tool and no problems were found.

Posted Image

Note that I removed Computer Name and Page file - their info is irrelevant, in my opinion.

I do have a DirectX directory, that I believe was created with the initial install of Windows XP SP2 that came with my Dell. This directory, C:\WINDOWS\system32\DirectX, is empty of files. However, there is a Dinput subdirectory, C:\WINDOWS\system32\DirectX\Dinput, that contains 33 Configuration Settings files, and 147 PNG Image files.

Regarding anti-virus programs, I run Avira AntiVir 9.0.0.422 - where I run Avira AntiVir Guard to protect my system from real-time virus and adware/malware problems. I manually update the definition files at least twice daily.

Regarding adware/malware problems, as a redundant program to Avira, I also have Ad-Aware AE installed - though in a passive mode only. In other words, Lavasoft Ad-Aware Service is disabled when Ad-Aware AE is not being run - with its Real-time Protection off. In addition, the Ad-Watch option is also disabled. In short, I rely on Avira for adware/malware protection and use Ad-Aware to manually scan my system one, maybe twice a week.

I do not schedule any software updates, and always disable the automatic update option or preference.

After running both Avira and Ad-Aware, my system appears to be free of viruses and adware/malware.

Carefully following the direction of Marc Liron, Microsoft MVP 2010, as detailed here... http://www.updatexp.com/scannow-sfc.html ...I executed sfc /scannow, but it did not resolve the Missing or corrupted DxSetup.exe problem. Hopefully, it did not create other problems.

It do not know if it has any relevance, but I recently removed Microsoft Messenger (entirely) from my system. Having never used it, its' Service was disabled, and its' option in Outlook Express had been removed, for over 2 years,

Other than reinstalling my operating system, anyone have a solution or suggestions of how I can resolve this Missing or corrupted DxSetup.exe problem?

Thanks in advance,

CurlySue :flowers:

Edited by curlysue-tew, 21 July 2010 - 04:43 PM.


BC AdBot (Login to Remove)

 


#2 curlysue-tew

curlysue-tew
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:44 AM

Posted 30 July 2010 - 02:33 PM

No help?

LOSERS!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users