Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows shows Incorrect Drive Capacity


  • Please log in to reply
8 replies to this topic

#1 I_am_CanadianEh?

I_am_CanadianEh?

  • Members
  • 489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 21 July 2010 - 10:35 AM

Hi Fellow Bleepers! :thumbsup:

Wondering if someone has any insight:
- I had a Dual Boot setup on my 40GB Hard Drive. There were 2 partitions, each approx. 20GB each.
I decided I no longer need the dual boot, so I modified the boot.ini file and deleted the partition (which had XP installed on it). After rebooting, all was well and it booted normally, but I had some unallocated space of where the partition used to be.

Next, I decided to resize my existing partition (which is currently 20 GB) with the unallocated 20GB remaining. I used GParted Live CD for the process. I dragged the handle from the Primary partition across the unallocated space to make a single partition to cover the entire 40GB on my HDD.

I then rebooted into Windows and checked my drive.
In Computer Management, it showed it had 39.75GB, BUT in My Computer it only showed 19.7 GB!! :flowers:

What happened? I know the drive is 40 gigs, but Windows doesn't "see" it after the merge. Computer management shows it correctly.

I ran CHKDSK C: /f on the main partition but there were no errors and the problem remains.

Computer Specs.
Dell Latitude D610
1 GB DDR2 SDRAM
Single Core Pentium M Processor 1.6 GHz
Integrated Intel Graphics
Windows XP Pro SP3 fully patched to July 2010
BIOS is fully up to date as well as the Mobo & Chipset drivers.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,558 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:41 PM

Posted 21 July 2010 - 10:48 AM

A 40GB drive...should only reflect 37.5GB of space in Windows.

I don't know what happened (never used GParted) but all I can suggest is to try it again.

What is reflected when you view from the software used?

Louis

#3 I_am_CanadianEh?

I_am_CanadianEh?
  • Topic Starter

  • Members
  • 489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 03 August 2010 - 10:50 PM

Checked again using Partition Wizard.
My physical disk shows 37.5 GB which is correct. Then it shows only one other partition, the Windows one, with 19.7GB only.

I ran Chkdsk without a switch and it mentioned that I had a problem with "free space marked as allocated" and a problem with the Master File Table. Great! All I need to do is run chkdsk /f on the partition right?

Did that, it asked me if I wanted to check the disk after restart, I selected yes.
It did its thing, but it did not correct the errors. It didn't even mention that it had errors. :flowers:

So Chkdsk without the /f switch tells me I have errors, but Chkdsk /f runs through without mentioning any errors and it doesn't correct them.
I have no bad sectors on my drive.

My machine reboots and I'm back to Square one.

Now what? :thumbsup:

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,558 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:41 PM

Posted 04 August 2010 - 07:53 AM

You state that you deleted a partition...you now have 1 partition reflected correctly.

Hard drive size is stated correctly.

Run the chkdsk /r command on the one remaining partition, please.

Louis

#5 I_am_CanadianEh?

I_am_CanadianEh?
  • Topic Starter

  • Members
  • 489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 04 August 2010 - 09:14 AM

Running Chkdsk /r did not fix the problem. It reported the volume was clean and no errors found.
Chkdsk in read-only mode tells me it has errors...

Is there another way without using Chkdsk to repair these file errors?

#6 EverWin

EverWin

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:10:11 AM

Posted 04 August 2010 - 01:20 PM

hi

well this problem is with partition table & can't be solved by running check disk.

Man you have to back-up all your Important data to external drive than

download & Install Partition Wizard Home Edition 5.0 (its a freeware)

Resize Windows XP Partition by only 1GB Apply the settings PC will reboot, once it is done, run PWHE 5.0 again to check if the partition is resize correctly. now you can resize & use all unallocated free space.

if Partition is not resized, then it is clear tht thr is The Bad sectors in H.D.D

Note: This kind of Problem is fixed just by resizing Partitions. Recommended software to do so is (Acronics Director)

Regards,
Harjit

#7 I_am_CanadianEh?

I_am_CanadianEh?
  • Topic Starter

  • Members
  • 489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:41 PM

Posted 05 August 2010 - 09:02 AM

I solved the issue on my own. :flowers:

So, I reinserted the GParted Live CD and had a look at the partitions. It showed what Windows didn't; a single partition about 37.5 GB in size.
Right clicked on the partition and selected to Check the partition for errors, and then clicked APPLY. After a few seconds it completed but it didn't show what was fixed if anything.

So I removed the CD and rebooted the computer into Normal Windows. It immediately went into a CHKDSK and recommended strongly that I check for consistency. It did so, then rebooted.

When I opened up My Computer and checked the drive size....it was CORRECT at 37.5 GB. :thumbsup:

So, problem fixed...thanks to all those that attempted to help me. :trumpet:

#8 abauw

abauw

  • Members
  • 951 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kebun Kelapa
  • Local time:11:41 AM

Posted 05 August 2010 - 09:33 AM

Glad to hear your problem solved :thumbsup:

:guitar: Take me to a place where time is frozen
You don't have to close your eyes to dream :busy:
You can find escape inside this moment :smash:
And I will follow  :whistle:


#9 hamluis

hamluis

    Moderator


  • Moderator
  • 56,558 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:41 PM

Posted 05 August 2010 - 09:34 AM

Thanks for posting your resolution, happy computing :thumbsup:.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users