Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External Hard Drive Not Recognized...Cooked?


  • Please log in to reply
3 replies to this topic

#1 Hockey_fan

Hockey_fan

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:14 PM

Posted 15 July 2010 - 02:34 PM

Hello everyone. I have a Comstar Platinum one touch 320GB external hard drive. Its been about 3-5 years since I bought it, and I have not used it for about a month now, maybe 2 months.

Problem: Whenever I connected the External Hard drive into my laptop, the LED Lights light up normally, but it does not vibrate normally either. It used to vibrate and make little noises and it would eventually get warm. Now, it just sits there with the blue LED lights on, no vibration, and it does not get warm, its just cold. My laptop does not read it, nothing pops up on my laptop.

I checked drive management, something like that, its not there anymore. I tried googling the external hard drive and the same problems, not a whole luck in my part.

Questions:
-How can I access the files on there?
- How to get it up and running again?


Thanks, I hope this problem can be fixed soon, and prevent anyone else's with the same problem.

BC AdBot (Login to Remove)

 


#2 JUICYboy

JUICYboy

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Anaheim, Ca
  • Local time:05:14 PM

Posted 15 July 2010 - 05:21 PM

Well the platters inside the hard-drive has to spin in order to take info out.

If it does not feel like it spins then the motor on the actual platters shaft burned out or something :thumbsup:

Anyways I tried to see if they had some troubleshooting software with no luck.

Maybe trying a different power chord but if its dead its dead. :huh:

Good luck

#3 Hockey_fan

Hockey_fan
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:14 PM

Posted 15 July 2010 - 07:22 PM

Yeah it doesnt vibrate, or spin anymore. Is this fixable?

#4 abauw

abauw

  • Members
  • 951 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kebun Kelapa
  • Local time:04:14 AM

Posted 17 July 2010 - 06:33 PM

try different external case...
maybe its you case failure that cause that...

:guitar: Take me to a place where time is frozen
You don't have to close your eyes to dream :busy:
You can find escape inside this moment :smash:
And I will follow  :whistle:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users