Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error Launching Class & Unhandled Exception


  • Please log in to reply
1 reply to this topic

#1 Live2Eng

Live2Eng

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Central Eastern US
  • Local time:08:36 PM

Posted 09 July 2010 - 10:11 AM

I get the following error in a pop up window:

Error launching Class hms.hms
with Java java\bin\javaw
Error=2

Downloaded latest java in 32 and 64 bit versions without change. Restored to state one week prior to issues without sucess (need I go further?)

I use this computer at work, and deliberately do little web surfing in hopes of keeping it clean. I built the machine about a year ago and loaded verry little software not work related and rarely use them past the initial trying-out-the-new-machine stage. I use it mainly for CAD (drafting and deisgn) because it can handle larger files. I also run a hydrology simulation program called hec-hms, version 3.4 which is the newest version. This program is developed and supported by the U.S. Army Corps of Engineers, however non-corps users are not supported by the corps. This program is widely used and there are many support forums for non-corps users. The error occurs when I start the program, but I suspect that the error is not specific to this program, but . . . what do I know? What I do know is that the error is new after many months of using this program daily, I also know that I uninstalled it, downloaded/reinstalled it anew from the USACE website without change.

The odd thing is that when searching this error, I only get one hit, which is for a forum submission with a similar problem. But there have been no responses to that post. I suspected perhaps a virus, but I would not get a virus on this machine unless it is somewhat common and therfore I expect to see some posts about it, again what do I know . . . my suspicions do not make it so.

I have had this problem for several days and posted in the Vista forum without success. This morning I got a new error from Autocad Civil 3d. Specifically:

FATAL ERROR: Unhandled e0434f4dh Exception at 7632e124h

I used the program everyday this week without trouble, but this morning it will not even start. I am thinking virus/malware.

I am hesitant to start running scans ad hoc, as my experience with such things is limited to XP and I do not know what difference Vista makes, and whether the Vista help out there always applies to the 64 bit version. I know the Combofix solution that has helped me in the past is not designed for the 64 bit version but do not know if there is a Combofix64 and am too wimpy to try it alone anyway.

Anyone else in this boat? Are there any lifejackets onboard?

BC AdBot (Login to Remove)

 


#2 ksreenivasu

ksreenivasu

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:36 PM

Posted 17 June 2017 - 11:31 AM

Hi,

I got the same problem. I have followed one of the repliers about path and solved it. Thank you.

What I did was:

I opened HEC-HMS.config file

at the beginning of the file, there is a path for java\bin\java and java\bin\javaw

I went to java program folder and copy the path for java.exe and javaw.exe under bin file which are looked something like

C:\Program Files (x86)\Java\jre1.8.0_131\bin\java.exe

C:\Program Files (x86)\Java\jre1.8.0_131\bin\javaw.exe

 

replaced original paths with these actual paths and ran HEC-HMS. it worked.

 

Thanks,
Sree


Edited by ksreenivasu, 17 June 2017 - 11:32 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users