Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Soooooooooooooo Complecated

  • Please log in to reply
3 replies to this topic

#1 Mr_Freeware


  • Members
  • 141 posts
  • Local time:09:13 PM

Posted 14 October 2005 - 08:53 PM


this is from the FAQ that came with the font maker.

How do I edit fonts on MS windows?
To run FontForge under MS windows you must first install the cygwin environment.

* First download the setup.exe program from http://www.cygwin.com/
* Run it. It will ask you what components of cygwin you wish to install
* You will need the base components, the X window system, xorg-x11-base, and xterm (NOTE: These are separate packages)
* Once you have cygwin installed, start it. This should give you a terminal window running bash (a unix shell)
* Download the cygwin version of FontForge, and move it to whatever directory you think most appropriate (/usr/local/bin is a reasonable choice)

$ mkdir -p /usr/local/share/fontforge /usr/local/bin /usr/local/man/man1
$ cd /tmp
$ tar xfzv fontforge_cygwin*.tar
$ cd fontforge
$ mv *.ui /usr/local/share/fontforge
$ mv fontforge.1 /usr/local/man/man1
$ mv fontforge.exe /usr/local/bin

Then edit the file ~/.bashrc by (or by whatever other tool you prefer):

$ cat >> ~/.bashrc
PATH=${PATH}:/usr/local/bin ; export PATH
MANPATH=${MANPATH:-}:/usr/local/man ; export MANPATH

* Then each time you want to run fontforge, type:

$ xinit

* This should bring up X in a large window that covers the screen and within that should be a subwindow, an xterm, running bash.
* From the xterm you should be able start FontForge.

$ fontforge -new

If you want to be able to build FontForge under cygwin, you will need to grab some other cygwin components, like gcc, the image processing libraries, freetype, etc.

this is sooooo confusing. i dont know what to do. there are so many problems. i went to http://www.cygwin.com/ and got the setup.exe. but it was SOOO wiered and confusing and didnt make sense AT ALL. my problem isnt so much with this, but with that setup.exe thing i downloaded. i have no clue whats going on here. :thumbsup:

BC AdBot (Login to Remove)


#2 Rimmer


  • Members
  • 2,159 posts
  • Location:near Sydney, Australia
  • Local time:12:13 PM

Posted 18 October 2005 - 04:24 AM

Complicated indeed....

So far as I can tell you have downloaded some kind of Unix emulator so that you can run shell scripts to enable you to load a font editor. Unless you speak Unix I'd suggest you will find this very difficult to cope with.

Is there no font editor native to Windows? I'm sure I've seen articles on such things - if that's what you're trying to do. :thumbsup:

Maybe this link will help?

Edited by Rimmer, 18 October 2005 - 05:03 AM.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#3 tg1911


    Lord Spam Magnet

  • Members
  • 19,274 posts
  • Gender:Male
  • Location:SW Louisiana
  • Local time:08:13 PM

Posted 18 October 2005 - 11:10 AM

Windows XP Home Edition contains a program called Private Character Editor.
Microsoft says that with this program it is possible to create up to 6,400 unique characters for use in your font library.

The Private Character Editor is not accessible from your Start Menu, which is why you might not have known that you had it; however, it can be started up through the "Run" option that is found in your Start Menu.

Click on the Start button, then Run....
In the Run window that appears, type in: eudcedit
Click OK.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#4 Mr_Freeware

  • Topic Starter

  • Members
  • 141 posts
  • Local time:09:13 PM

Posted 24 November 2005 - 09:16 PM

sorry guys. i lost interest. thanks for the help. i keep forgeting to check back on my posts here.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users