Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ati Catalyst


  • Please log in to reply
8 replies to this topic

#1 chocobowing91

chocobowing91

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 14 October 2005 - 08:19 PM

hello i justbought a radeon 9600 pro but i cant get the ati catalyst control center to work. every time i click on it the hard drive clicks but nothing ever shows up. can anyone tell me how to fix this plz! :thumbsup:

BC AdBot (Login to Remove)

 


#2 Gothmog

Gothmog

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 15 October 2005 - 02:29 AM

even though you just bought the card have you gone to the ati website for latest updates? sometimes the drivers in the box can be a little out of date and a newer version of catalyst might solve ur prob. i recently went there and got updates for my 9000 card and found it a fulfilling experience ;)

by click do you mean a normal spin up noise or a repetitive click noise? if it is the latter u may be facing imminent doom. I had one start clicking and within a week it was completely unreadable and had to send it back to Maxtor(I just love waiting on automated phone lines for RMAs)

#3 chocobowing91

chocobowing91
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 16 October 2005 - 12:08 AM

HD was clicking like it always does when it is trying to do something, regular hard drive noise. but ati catalyst just wont show up on the screen,however the taskbar thingy does show up i just cantbring up the actual control center. also, what is the latest driver and where can i get it please? thx! my current is 5.1.

Edited by chocobowing91, 16 October 2005 - 12:08 AM.


#4 rms4evr

rms4evr

  • Members
  • 812 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:East Coast
  • Local time:11:22 AM

Posted 16 October 2005 - 02:47 PM

the latest display for any ati system can be found here:

Ati display drivers

you have to pick your OS and video card, and it'll take you to the latest driver. However, it is a 5.10, which may be the same as yours. I have a 7000 Ati Radeon mobile card, and my driver is ALWAYS acting up! It's frustrating, I know. If you are running on Windows they sometimes have hardware updates for supported display drivers on their website.

If you're feeling bold, you could try these:

Omega drivers

I recently started using these drivers, and so far I'm happy with them! They might be compatible with your system, but microsoft doesn't support them, so be careful! Of course, I'm NOT a computer expert, so if you want to ignore me, I won't take it personally. Hope you can solve your problem!

#5 chocobowing91

chocobowing91
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 16 October 2005 - 10:17 PM

omega works great thanks alot!

#6 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:22 AM

Posted 17 October 2005 - 06:10 PM

Just a note here. Using the Omega drivers is a good thing and may help you out considerably. BUT...If you start having video problem, the best thing to do it to uninstall them and install the WHQL certified drivers.

I say this because the WHQL certified drivers are certified by Microsoft to work with Windows. And, any troubleshooting by Microsoft will start by asking this - if not, they won't help you without getting money from you.

If you have the problem with the the video and you're using the WHQL drivers, and your problem fits their criteria - then they'll help you troubleshoot the problem for free. They've done it several times for me (and, admittedly, each and every problem has been caused by my using either non-WHQL video drivers or unsigned drivers).

You can check for signed drivers by using the sigverif.exe tool (in XP) on your system32 sub-directory.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#7 chocobowing91

chocobowing91
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 17 October 2005 - 09:01 PM

ok thx. :thumbsup:

#8 chocobowing91

chocobowing91
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:22 AM

Posted 17 October 2005 - 09:01 PM

ok thx. :thumbsup:

#9 rms4evr

rms4evr

  • Members
  • 812 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:East Coast
  • Local time:11:22 AM

Posted 17 October 2005 - 09:25 PM

Hrm... might be worth checking out. Thanks usasma! :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users