Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Redirect Virus


  • Please log in to reply
No replies to this topic

#1 HayLizz

HayLizz

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:44 AM

Posted 26 June 2010 - 03:50 PM

I have a virus that appears to infect nothing other than my browsers, thankfully. My default and preferred browser is Google Chrome, but when I try to open Google Chrome, it just doesn't load. For some time, I was getting "unresponsive pages" error that gives you the options "wait" or "kill pages". I apologize that I don't have the exact error message for you.

How I discovered the virus: I've really wanted Kaspersky Anti-Virus for some time now, but it's spendy. I decided I would download the free trial until I figured out a way to get the full version. I knew Kaspersky would not run with other ant-virus/spyware/malware programs, so I removed PC Tools (my dad had installed it on reccomendation of Dr. Phil) and tried to access Kaspersky.com. There was no activity between these two actions. When I try to access Kaspersky in IE, I recieve the "Cannot Find Server" page. The page cannot be displayed, click here for internet connection help, etc. I also recieve a yellow bar just under my toolbar saying "This website wants to run the following add-on: 'Shell-Doc Object and Control Library' from 'Microsoft Corporation'. If you trust the website and the add-on and want to allow it to run, click here..." Obviously, there's no website to be found so I have completely ignored this. If I use a search engine to access a website, I am redirected to random ad pages from all over the place. I can access websites like Facebook, bleepingcomputer, and a plethora of anti-virus/malware/spyware sites and can even download them, but cannot acess Kaspersky website or websites through search engines. Sometimes, I'll be redirected to an ad page when I try to head to Facebook or Microsoft Security Essentials, but can access the website on the second or third try.

I have already performed one full and one quick scan using MBAM. The first full scan detected somewhere around 40 threats and I had MBAM remove and delete all of them, but the virus stayed. The second quick scan by MBAM detected nothing. I have now uninstalled MBAM and am running a full scan with Microsoft Security Essentials, which has found/removed on threat, but I have a feeling it won't help much. I still get redirected when I boot up in safe mode.

EDIT: Moved from XP to Am I Infected forum ~ Hamluis.

UPDATE: Ran Kaspersky TDSSKiller. Found nothing, redirect still there, Chrome still dead.

Edited by HayLizz, 26 June 2010 - 06:14 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users