Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trying to install Dell Dimension C521 Drivers


  • Please log in to reply
4 replies to this topic

#1 manjarez

manjarez

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 24 June 2010 - 06:20 PM

I reinstalled my XP and now I need to reinstall my drivers which I know how to do I just don't know in what order to do it. Please translate for me. The Dell website says I'm supposed to install in this order for my computer:

1 - Desktop System Software
2 - Chipset
3 - Video Adapter
4 - Network Interface Card
5 - Audio Adapter
6 - Modem
7 - Wireless Network Card
8 - Mice, Keyboards

But when I put my driver cd in these are the ones listed for my computer:

Video Drivers
Audio Drivers
Controller Drivers
Miscellaneous Utilities
Modem Diagnosis
Modem Drivers
Network Diagnosis
Network Drivers
System Applications
System Dell Diagnosis
System Drivers
Video Diagnosis

In what order do I install these? (Note: if they don't label it exactly the same I don't know what I'm doing and they're confusing me here lol). So just looking at my drivers and the order in which they say to install can you tell me what order I install mine?

Thanks,
Jen

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:05:31 PM

Posted 24 June 2010 - 07:19 PM

What matters is to install chipset driver first. After that, any order is fine.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 manjarez

manjarez
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 24 June 2010 - 08:17 PM

Well I put them in but now when I scroll down in my web browser it is choppy and stalls. It doesn't scroll smoothly.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,091 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:31 PM

Posted 24 June 2010 - 08:49 PM

Uninstall, then reinstall your video drivers (I've had this happen).

Louis

#5 manjarez

manjarez
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 24 June 2010 - 09:10 PM

OH GOD! THANK YOU so much! My computer is finally fixed! :thumbsup:

Thank you, luis!!
Jen




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users