Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft Visual C++ Executable Running Environemnt


  • Please log in to reply
2 replies to this topic

#1 PropagandaPanda

PropagandaPanda


  • Malware Response Team
  • 10,433 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:58 AM

Posted 19 June 2010 - 11:19 AM

Hello.

I'm using Visual C++ Express 2010. When I run a file form the editor using F5, it does not allow the executable to access data files inside the Debug folder. I can work around this most of the time by clicking the .exe in the Debug folder, but I can't when Debugging.

Is there a setting that changes this?

Thanks,
The Panda

BC AdBot (Login to Remove)

 


#2 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:10:58 PM

Posted 19 June 2010 - 11:33 AM

Yes. Under project properties:
Debugging (on treeview at left) -> Working Directory. It defaults to $(ProjectDir) but you can change it to $(TargetPath) to have the working directory be the debug folder.

Billy3
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#3 PropagandaPanda

PropagandaPanda

  • Topic Starter

  • Malware Response Team
  • 10,433 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:58 AM

Posted 19 June 2010 - 12:14 PM

Got it. Thanks Billy.

The Panda




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users