Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Re-enabling CD autoplay


  • Please log in to reply
2 replies to this topic

#1 MattB85

MattB85

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:29 PM

Posted 11 June 2010 - 08:35 AM

I had a nasty Vundo/Virtumonde infection on my XP Pro SP2 system. After a week of effort and great help from some security experts I was able to remove it. However, I believe one of the tools I used to clear the infection disabled autoplay. I like having a CD or DVD start playing when I put it in the drive. I've tried enabling autoplay (on CDs only, deliberately disabled it on removable media like flash drives) using TweakUI but it doesn't seem to work. I also checked the registry for the entry that disables autoplay and it isn't present. Any ideas on how to fix this issue?

Edited by MattB85, 11 June 2010 - 08:36 AM.


BC AdBot (Login to Remove)

 


#2 Brother Bill

Brother Bill

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kansas City, MO
  • Local time:07:29 PM

Posted 11 June 2010 - 09:22 AM

To change or add the necessary entry in the register, you can try this. But only do this if you're comfortable making changes in your registry. An error in your registry can have disasterous results. I recommend backing up your registry first.

Click on Start > Run, type in regedit to open the registry editor.

Navigate through the following folders.

HKEY_USERS > .DEFAULT > Software > Microsoft > Windows > CurrentVersion > Policies > Explorer

In the Explorer folder, double-click the "NoDriveTypeAutoRun" if present and change the value to "91"

If "NoDriveTypeAutoRun" is not present, click "Edit" from the drop down menu, select "New", select "Binary Value".

Type in "NoDriveTypeAutoRun" as the name (without quotes) and press "Enter". Press "Enter" again to access the "Edit Binary Value" interface, enter "91" as the value, click "OK", exit regedit and reboot.

You should be good to go.

#3 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,541 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:08:29 PM

Posted 11 June 2010 - 11:56 AM

Download and run the Autoplay Repair Wizard from Microsoft
I have used it many times with success

That way you dont have to do any registry tweaks which could be dangerous
In the beginning there was the command line.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users