Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

IP address is 0.0.0.0


  • Please log in to reply
6 replies to this topic

#1 Megaritz

Megaritz

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:25 PM

Posted 10 June 2010 - 08:54 PM

My problem started when my computer froze up. I was unable to move my mouse or do anything else. I turned my computer off and back on, and when it came back on, the first thing I noticed was that the visual theme had changed to one resembling an earlier version of Windows. I eventually found a solution to that.

Now the remaining problem is that I can't connect to the internet. I am "connected" to my wireless network, but it says "limited or no connectivity." My IP address is listed as 0.0.0.0. When I use the "repair" option for my wireless network, it says it can't renew my IP address. It says the problem is probably with the network. Internet Explorer also says that. However, I know the problem is strictly with the computer itself. In spite of that, I tried unplugging the modem and router, and plugging them back in. Didn't work.

When I renew the IP address myself, it just stays the same--0.0.0.0. I can't connect to the internet this way.

I use a Toshiba Portege M400-S5032 with Microsoft Windows XP Tablet PC Edition 2005. I have a Netgear 54 Mbps Wireless Router WGR614 v7. Please be patient with me, as I don't know anything about how wireless networking works, or very many technical terms assosciated with it.

BC AdBot (Login to Remove)

 


#2 Retirednow

Retirednow

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 11 June 2010 - 01:13 AM

Right now it appears that your pc is not talking to your router based on the all zero IP address, Two things: 1. go to device manager and see if there are any yellow flags or red X's next to your network adapters. 2. Open a command prompt and type the following without the quotes and paste the results back here, "ipconfig /all".

#3 Megaritz

Megaritz
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:25 PM

Posted 11 June 2010 - 02:48 PM

I checked, and there are no yellow flags or red x's next to any of my network adapters in the Device Manager.

Here's what I got from ipconfig /all. I didn't bother with an accurate number of periods in between things, but it has all the information.

Windows IP Configuration

Host Name.......:M400-20
Primary Dns Suffix.......:
Node Type.....:Unknown
IP Routing Enabled.....:No
WINS Proxy Enabled......:No

Ethernet adapter Local Area Connection:

Media State.........: Media dosconnected
Description..........: Intel<R> PRO/1000 PL Network Connection
Physical Address.......: 00-15-B7-AF-0D-EB

Ethernet adapter Wireless Network Connection:

Connection-specific DNS suffix...:
Description..........: Intel<R> PRO/Wireless 3945ABG Network Connection
Physical Address........: 00-1B-77-76-EA-39
Dhcp Enabled.......: Yes
Autoconfiguration Enabled.......: Yes
IP Address.............: 0.0.0.0
Subnet Mask..........: 0.0.0.0
Default Gateway........:
DHCP Server.............: 192.168.1.1
DNS Servers..............: 192.168.1.1

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,287 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:25 PM

Posted 11 June 2010 - 03:04 PM

What you currently reflect...is what appears on this system when I type the ipconfig /release command.

I would try the following:

Open a command prompt and type "ipconfig /release," which dumps the automatic address it had, and then "ipconfig /renew," which gets a new address.

Louis

If that doesn't work, try the ipconfig /release command...followed by ipconfig /renew.

Edited by hamluis, 11 June 2010 - 03:05 PM.


#5 Megaritz

Megaritz
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:10:25 PM

Posted 11 June 2010 - 06:40 PM

Results for "ipconfig /release":

Windows IP Configuration

No operation can be performed on Local Area Connection while it has its media disconnected.
IP address for adapter Wireless Network Connection has already been released.



I also tried "ipconfig /renew" and this is what I got:

Windows IP Configuration

No operation can be performed on Local Area Connection while it has its media disconnected.
An error occured while renewing interface Wireless Network Connection : The RPC server is unavailable.

#6 hamluis

hamluis

    Moderator


  • Moderator
  • 56,287 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:25 PM

Posted 11 June 2010 - 06:54 PM

I don't do wireless...but I'd say that your hardware is fouled up, according to those messages.

Worth Reading.

Louis

#7 Taomech

Taomech

  • Members
  • 36 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:01:25 PM

Posted 14 June 2010 - 01:05 AM

Hi Megaritz,
There is a work around for your problem, though it may cause issues later if you add devices to your network or are on a corporate one.
If you would still like to continue, then please follow the instructions below.

1. Open up the wireless connections screen, the one that shows the available networks. This can be done by double clicking on the wireless icon in your taskbar and select "View Wireless Networks".
2. On the Wireless Connection screen, press Change Advanced Settings. This will bring up a dialog box.
3. Under "This connection uses the following items", scroll down to "Internet Protocol (TCP/IP) and double click it.
4. This will bring up another box. Change the "Obtain an IP address automatically" to "Use the following IP address."
5. In IP Address, type in the numbers 192.168.1.90
6. In Subnet Mask type 255.255.255.0
7. In Default Gateway, type 192.168.1.1

Go down to the Preferred DNS server area.

1. In Preferred DNS server type the numbers 8.8.8.8
2. In Alternate DNS server type the numbers 8.8.4.4


Click ok on the dialog box. It should ask you to restart your computer. Do this.
When it has restarted, connect to your network as you would normally. It should connect properly.
If you have any questions about these instructions, please ask me before going ahead.

Thanks,
Taomech

Edited by Taomech, 14 June 2010 - 05:42 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users