Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WD external HDD 500GB not working on vista


  • Please log in to reply
1 reply to this topic

#1 ma3zooz

ma3zooz

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:46 PM

Posted 18 May 2010 - 04:50 PM

Hey I'm new to this, so I hope I'm posting in the right section.

I've had this external hard disk drive from Western Digital 500GB for a while now, over a year. It's worked perfectly so far and I've been filling it lovingly with safe data around 400GB so far.
Recently I plugged it into the same computer that I have (running vista), and it wouldn't work. It wouldn't appear on my computer or on disk management. I thought that was the problem and reinstalled some drivers. Later I realized it was initializing, but it was taking a very long time. Around 10-15 mins to appear on my computer and disk management, and it would usually freeze all other processes while it was being initialized, also note that autoplay does not appear anymore. I've never had this problem before with it taking so long, and its been at 400GB for a while before this and working perfectly. i dont know why brand it is exactly, but it has a weird case which has A-byte written on its side, and requires a USB connection as well as a separate power supply. also, it might be important to state the obvious that the normal lights and sounds occur. ive tried it on a friends computer and similar things happen, so im pretty sure its not the laptop.

After some hopeless searching, I tried a couple of things. i tried downloading TweakUI, but to no avail as it does not work on vista for some reason. chkdsk fails, or rather i leave it for hours and come back to find it "completed" but it only checks 36 files out of millions, without any errors to report. i tried downloading WD lifeguard diagnostics.. the drive letter registers as a logical drive H:/ and only registers as a generic USB disc on the physical drive list (i dont know if this means anything).
the quick test passes with flying colors. as for the extended test, i just ran it, it completed and reported bad sectors, tried to repair them, but reported that it cant repair all of them. im doing it a second time now, just to be sure.
im out of ideas and i appreciate ANY help anyone can give me!! i cant format it as theres a lot of important data in it..

oohh i forgot to mention.. i tried opening up its properties and was surprised to find under the owner details: "Unable to display current owner" and when i try to change it i get "access denied".. though no one else uses this HD or computer.. also when i try searching for a file from start>search .. i get "a search location could not be reached"..

i kno this is lengthy, but i have tried to be as comprehensive as possible..

BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:46 PM

Posted 18 May 2010 - 07:47 PM

It sounds as if you have a Western Digital hard drive in generic enclosure. I would remove the HDD from the case and install it into a PC and see if you can get important files off of it before it possibly gets worse and stops working all together. The HDD has errors as chk disk has revealed. While the drive is installed in the tower you can also run the manufacture Diagnostic software from Western Digital found here you will need to burn this to a CD and reboot the computer from the CD lastly make sure you select the correct drive when testing (I have chose the wrong drive before LOL :thumbsup: ) Run the long and short tests

Edited by Sneakycyber, 18 May 2010 - 07:47 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users