Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows 7 starts power saving during games

  • Please log in to reply
3 replies to this topic

#1 455826


  • Members
  • 15 posts
  • Local time:11:22 PM

Posted 18 May 2010 - 04:21 PM


I recently re-installed my computer with windows 7 Professional.
It works perfectly, but the only thing that bothers me is the power saving.

When I start a big game (like settlers 7, just cause 2) my pc goes to power saving mode, that leads to a black screen.
The pc freezes, and I have to manually restart the computer.

It only happens with big games (and my computer matches the requirements), not small games, programs etc.

I switch off powersaving in control panel/power options/change plan settings, but that doesn't solve the problem.

I hope someone can help.

Thanks in advance,

BC AdBot (Login to Remove)


#2 MrBruce1959


    My cat Oreo

  • BC Advisor
  • 6,378 posts
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:11:22 PM

Posted 18 May 2010 - 05:56 PM

Hello and Welcome to Bleepingcomputer!

I read your discription above and need to ask you to supply your computers brand name and model number, laptop or desktop.

Many thanks in advance.

Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
My Career Involves 45 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#3 Yateesh


  • Banned
  • 24 posts
  • Local time:11:22 PM

Posted 19 May 2010 - 12:03 AM

:huh: Hi,

To force Windowed Mode in Settlers 7, you can do the following:

* Try pressing ALT+ENTER.

* Also try changing the value of the variable FullScreen, to 0. Go to your MY Documents folder, and then locate the Settlers7 folder, and Open the Options.ini config file inside it with Notepad. Now look for the following lines:

FullScreen = 1
ScreenHeight = 1024
ScreenWidth = 1280

Change the value of FullScreen to 0, and Save the file.

This file should be located here: 'C:\Documents and Settings\YourName\My Documents\Settlers7\Options.ini', Or 'C:\Users\USERNAME\Documents\Settlers7\Options.ini'. If the game still doesn't start in Windowed Mode, then you can try using these Tools, which I'm giving. Follow the instructions carefully.



For 3D-Analyze: DL this program, and then Select the Game's exe e.g. settlers7.EXE, and click on the RUN button. But first make sure to *Check/Tick* the option Force Windowed Mode, under the Performance heading/tab.

This 'Black Screen' on game's launch/start, could be related to the in-game Resolution. But I'm NOT sure. You can check the Game resolution values in the above 'Options.ini' file. Just check whether the correct Resolution values are entered, which your Monitor supports.

All this is to be followed, if all the system configuration requirements meet for the game and for the operating system.


Edited by Yateesh, 19 May 2010 - 12:05 AM.

#4 455826

  • Topic Starter

  • Members
  • 15 posts
  • Local time:11:22 PM

Posted 19 May 2010 - 03:34 AM

thanks for the replies.

-I bought the computer in a local computershop, so I don't think it's a brand.
System specs:
AMD 7850 Dual 2.8GHZ (ECS elitegroup)
4GB Ram
Geforce 9500 1GB

-I'll try the windowed Mode this afternoon. I will reply as soon as I know more.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users