Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Files and Folders out of order


  • Please log in to reply
22 replies to this topic

#1 dorje

dorje

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 17 May 2010 - 03:39 PM

Hi,

I've had this problem for a while - it's nagging and slows me down, but it's not deadly.

When I display a folder's contents in Windows Explorer or even in the file open dialog of a program like Photoshop, the files are not in any specific order, and certainly not in the expected default order, which is "by name".

I've already specified View>Details in the View options of the Explorer window, and applied it to all folders using Tools>Folder Options>View>Apply to all folders.

Problem is, while the details view always shows up, the files seem to be in random order. I always have to click on a column heading to get them in any order at all. (In Photoshop's Open File dialog, I have to right click the window and specify "Arrange Icons by Name". The next time I open that same directory/folder, the files will be in random order again).

They used to show up in name order all the time. A few months ago that stopped happening.

One thing I have noticed is that in a given folder, the last subfolder that I accessed will be at the top of the name listing and maybe a few more recently accessed folders will follow it. But after that, the order seems random again.

I am truly puzzled. I suspect a registry entry is the problem, but I don't know which one.

Thanks for your time!

Dorje

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,246 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:54 PM

Posted 17 May 2010 - 03:58 PM

I've seen this a couple of times, but...I have no explanation for it.

What I ususually do is run chkdsk /r and defrag the partition, which seems to work.

Louis

#3 Baltboy

Baltboy

    Bleepin' Flame Head


  • BC Advisor
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:07:54 PM

Posted 18 May 2010 - 10:38 AM

You have double checked the view-arrange icons by setting to be sure name is selected and auto arrange is selected?
Get your facts first, then you can distort them as you please.
Mark Twain

#4 dorje

dorje
  • Topic Starter

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 18 May 2010 - 08:03 PM

I've seen this a couple of times, but...I have no explanation for it.

What I ususually do is run chkdsk /r and defrag the partition, which seems to work.

Louis


I run chkdsk /r and defrag regularly, but just to be sure, I ran them again last night, and today I still have the problem.

Thanks for your advice, anyway!

Dorje

#5 dorje

dorje
  • Topic Starter

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 18 May 2010 - 08:05 PM

You have double checked the view-arrange icons by setting to be sure name is selected and auto arrange is selected?


As for "name", it is selected, always. The "auto arrange" option is greyed out, and has been since I can remember. The only time I ever see that option active is on the desktop. Is that normal, or is it a clue?

Thanks.

Dorje

#6 tjwh

tjwh

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:02:54 AM

Posted 19 May 2010 - 05:18 AM

You could try:
view -> details
arrange icons by name
view->icons

#7 Baltboy

Baltboy

    Bleepin' Flame Head


  • BC Advisor
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:07:54 PM

Posted 19 May 2010 - 11:54 AM

Auto arrange should never be grayed out that I have ever seen
Get your facts first, then you can distort them as you please.
Mark Twain

#8 Baltboy

Baltboy

    Bleepin' Flame Head


  • BC Advisor
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:07:54 PM

Posted 19 May 2010 - 12:31 PM

Auto arrange only works when you display Icons then you can choose auto arrange.


edit: So using detail mode greys in out. try switching to icon -use auto arrange- then you can swith back to details if you like.

Edited by Baltboy, 19 May 2010 - 12:32 PM.

Get your facts first, then you can distort them as you please.
Mark Twain

#9 dorje

dorje
  • Topic Starter

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 19 May 2010 - 01:19 PM

You could try:
view -> details
arrange icons by name
view->icons


Thanks, I just tried that. I can arrange any folder any way I want, with details or icons.

The issue for me is that the folders don't stay arranged, and that any given folder will display the files/folders in it in random order, rather than any specific order.

I can then rearrange said folder the way I like, but the next time I visit it, it will be random again, until I explicitly re-order it.

Dorje

#10 dorje

dorje
  • Topic Starter

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 19 May 2010 - 01:23 PM

Auto arrange only works when you display Icons then you can choose auto arrange.


edit: So using detail mode greys in out. try switching to icon -use auto arrange- then you can swith back to details if you like.


Hi, Baltboy,

Thanks for the catch, re. Auto Arrange only works with icons. You're absolutely right.

Problem is, Auto Arrange doesn't put the icons in any specific order, it just aligns them with an invisible grid. It doesn't change the order within the grid.

If you were to sort by name order (while displaying icons), then Auto Arrange, you've got a sorted grid of icons.

What I'm trying to figure out is why, even after I sort the contents of a folder, the next time I open it, it's random again?

Dorje

#11 thicool

thicool

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kentucky, USA
  • Local time:07:54 PM

Posted 19 May 2010 - 01:25 PM

did you make any major changes to your system around the time that this problem surfaced? or can you remember

#12 dorje

dorje
  • Topic Starter

  • Members
  • 143 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR, USA
  • Local time:04:54 PM

Posted 19 May 2010 - 01:28 PM

did you make any major changes to your system around the time that this problem surfaced? or can you remember


I don't remember making any major changes to the system around that time, but that doesn't mean I didn't do it :thumbsup: !

I've done some head-scratching and can't come up with anything. This is my development/working system, so I tend to leave it alone except for maintenance, and fiddle with other systems.

Thanks.

#13 thicool

thicool

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kentucky, USA
  • Local time:07:54 PM

Posted 19 May 2010 - 03:17 PM

this may provide some assistance...

http://www.cc-tips.com/LPMArticle.asp?ID=37

#14 666philb

666philb

  • Members
  • 130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:uk
  • Local time:12:54 AM

Posted 19 May 2010 - 05:07 PM

when using the 'apply to all folders' option from the tools menu, make sure you do select this whist in the 'my computer' folder

#15 Baltboy

Baltboy

    Bleepin' Flame Head


  • BC Advisor
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:07:54 PM

Posted 21 May 2010 - 07:27 AM

Go to my computer. Ste the parameters you want with icons- name- auto arrange. Then go to tools-folder options-view- apply to all folders- okay.
Get your facts first, then you can distort them as you please.
Mark Twain




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users