Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet not working - failed to query tcp/ip - ipconfig internal error


  • Please log in to reply
3 replies to this topic

#1 magogami

magogami

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:16 PM

Posted 07 May 2010 - 05:59 AM

I ran a couple of spyware scanners and my AntiVir scanner, but after eliminating what they found, I can't get on the internet anymore. When I try to repair the connection, it immediately pops up with a box saying something like "windows cannot continue repairing... failed to query tcp/ip." I've tried numerous things but they haven't done anything. It says the connection is connected even though the internet isn't working. I also had to reinstall winlogon32.exe and winlogon86.exe because my computer wouldn't log on (it would begin to log on but then immediately log off again).

Also, I tried to use System Restore, but the restore points must be corrupted or something because each time I try to restore to an earlier time, the system restore says "installation incomplete," so I guess that is out of the picture? I am able to make new restore points I just can't restore to the points.

I get this when doing any ipconfig commands in cmd:
"Windows IP Configuration
An internal error occurred: The request is not supported.
Please contact Microsoft Product Support Services for further help.
Additional information: Unable to query host name."

There is a yellow exclamation point by the TCP/IP Protocol driver in Device Manager.

I also tried the method described here http://www.geekstogo.com/forum/faile...ml&hl=ipconfig to rename tcpip.sys to tcpip.sys_old but my computer didn't give a warning like it did for the guy who talked about this method. So then I used my XP cd to reinstall the tcpip.sys files but it didn't do anything. Also, I changed about 6 tcpip.sys files but there were only 2 on the CD.

I also tried winsockfix and some netsh commands (along with this program http://support.microsoft.com/kb/299357 which didn't do anything.

Is there some way to just like reinstall the internet connection part of windows from scratch? I'd prefer not to repair install windows because I just did it a few months ago and it was a hassle, and also because I think I read online that it didn't fix the problem for other people with the issue.


Thanks for your help in advance!

Edited by magogami, 07 May 2010 - 06:35 AM.


BC AdBot (Login to Remove)

 


#2 marktreg

marktreg

  • Members
  • 403 posts
  • OFFLINE
  •  
  • Local time:07:16 PM

Posted 07 May 2010 - 12:43 PM

There's some good info about the problem here:

http://smokeys.wordpress.com/2008/07/20/ho...p3-tcpip-stack/

I hope this helps. :thumbsup:

#3 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:07:16 PM

Posted 07 May 2010 - 01:25 PM

winlogon32 and winlogon86 sounds like viruses to me. There should only be one winlogon.exe.

SO I would perform a scan on your system.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,095 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:16 PM

Posted 07 May 2010 - 01:41 PM

Winlogon86.exe Data.

Louis

BC Am I infected What do I do - http://www.bleepingcomputer.com/forums/f/103/am-i-infected-what-do-i-do/

Edited by hamluis, 07 May 2010 - 01:42 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users