Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


No CD/DVD drives?

  • Please log in to reply
6 replies to this topic

#1 Skyty


  • Members
  • 17 posts
  • Local time:01:14 AM

Posted 04 May 2010 - 11:57 AM

Okay, so for some reason my CD/DVD drives are not showing up on 'My Computer'

I have absolutely no idea what could have caused this.

I did some Google searching before this but none of the methods I found seemed to work.

Has anyone else experienced this problem and managed to fix it?

Thanks for any help :thumbsup:

BC AdBot (Login to Remove)


#2 nitekram


  • Members
  • 41 posts
  • Local time:01:14 AM

Posted 04 May 2010 - 12:10 PM

It could be an issue with the drive itself. Is it a laptop or desktop? If a desktop, there might be a loose connection. If it is a laptop, can you take the drive out and test it somewhere else?

#3 Queen-Evie


    Official Bleepin' G.R.I.T.S. (and proud of it)

  • Members
  • 16,485 posts
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:12:14 AM

Posted 04 May 2010 - 12:10 PM

What methods have you used to try to resolve the issue?

It would be helpful if we know what you've already tried.

If one of them wasn't this, try it.

From Start Menu/Control Panel.

Administrative Tools/Computer Management/Device Manager.

Under DVD/CD Rom Drives, does it show up?

If it does, RIGHT click on the drive, then UNINSTALL.

Reboot and hopefully it will find it.

If you don't see it listed, try clicking on DVD/CD Rom Drives and scanning for hardware changes.

#4 Skyty

  • Topic Starter

  • Members
  • 17 posts
  • Local time:01:14 AM

Posted 04 May 2010 - 12:26 PM

I can't really remember the method but it was something about going into the Registry and deleting some upper and lower filters or something like that. The other there was a little .exe file the when you run it, it fixes the issue. Neither methods worked.

The drives are recognized, but they have a little yellow circle beside them with an '!' mark in it.

Do you know what that could mean?

#5 petewills


  • Members
  • 1,378 posts
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:06:14 AM

Posted 04 May 2010 - 01:02 PM

Queen-Evie's method usually does the trick. Right click on each drive in Device Manager, select uninstall and reboot.
Check device manager to see if the yellow warnings are gone.

Or you could try the automated fix-it program


Edited by petewills , 04 May 2010 - 01:03 PM.

#6 cryptodan


    Bleepin Madman

  • Members
  • 21,868 posts
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:05:14 AM

Posted 05 May 2010 - 11:59 AM

If what Queen-Evie suggests doesn't work you can always try removing the IDE Controllers, and rebooting then let windows reinstall them. You can find the IDE Controllers under device manager as well. This usually does the trick.

#7 Broni


    The Coolest BC Computer

  • BC Advisor
  • 42,770 posts
  • Gender:Male
  • Location:Daly City, CA
  • Local time:09:14 PM

Posted 05 May 2010 - 11:02 PM

Download, and run Restore Missing CD Drive patch
Double click on cdgone.zip to unzip it.
Right click on cdgone.reg, click Merge.
Accept registry merge.
Restart computer.

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users