Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet access problem


  • Please log in to reply
No replies to this topic

#1 catcher1

catcher1

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:02:47 AM

Posted 03 May 2010 - 07:13 AM

Hello

Lately I have been having internet access problem in my computer. It started about the same I replaced my faulty GPU (computer was turned off for 2 weeks until I got it replaced).

I am connected to the internet with a modem (one computer, no network) and a dialer configured according to ISP instructions.
I also applied a registry patch they asked to in a case of the dialer giving error message, when its first configured, like after windows reinstall:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters]
"ProhibitIpSec"=dword:00000001

I am using Windows XP SP3 with all windows update high priority updates (format and new OS installed a few days ago, which did not solve the problem).
I have updated drivers installed, including motherboard chipset and the onboard ethernet controller driver from manufacturers sites.

The problem details:
When connected to the internet with the dialer, every 5 minutes, there is a problem with internet access.
Looking in Network Connections window, the 'Marvell Yukon PCI-E Gigabit Ethernet Controller' line changes from 'Connected' to 'Acquiring network address'.
There is no internet access at that time, until its going back to 'Connected' after about 30 seconds.

Check the screenshot of Network Connections when the problem happens:
http://img197.imageshack.us/img197/7818/ne...connections.png - When there is internet access. But note the Lease Obtained/Expires - Set to expire 5 minutes from when its obtained??
Sometimes the IP address changes from [172.x - internet access OK] to [169.x - no internet access - acquiring network address until IP goes back to 172.x], and more rarely to [0.0.0.0 - Yellow exclamation for a minute until IP goes back to 172.x]
http://img341.imageshack.us/img341/3866/ne...onnections2.png - when IP changes to 0.0.0.0. (no internet access)
http://img63.imageshack.us/img63/9231/netw...onnections3.png - when IP changes to 169.x (no internet access)

Note, I did not check the actual IP address used for internet access (its showing when I click on the ISP dialer under Virtual Private Network area)

Below are the related Event Viewer Warnings/Error (they happen at the same time that the problem happens). Not sure about #5-#6 ones as they appear at different times, but content seems related to internet access so might help you to understand the cause.

1) Warning 1003 - Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 001Dxxxxxxx.  The following error occurred: 
The semaphore timeout period has expired. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

2) Error 1000 -  Your computer has lost the lease to its IP address 172.x.x.x on the Network Card with network address 001Dxxxxxxx. *Note: internet access OK with this IP*

3) Warning 1007 - Your computer has automatically configured the IP address for the Network Card with network address 001Dxxxxxxx.  The IP address being used is 169.x.x.x. *Note: no internet access with this IP*

4) Information 8033 - The browser has forced an election on network \Device\NetBT_Tcpip_{D01D94E9-8804-40B7-AF20-84B2895076B4} because a master browser was stopped. - Not Related?


5) Warning 2022 - The server was unable to find a free connection 37 times in the last 60 seconds.  This indicates a spike in network traffic.  If this is happening frequently, you should consider increasing the minimum number of free connections to add headroom.  To do that, modify the MinFreeConnections and MaxFreeConnections for the LanmanServer in the registry.

6) Warning 4226 - TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.

I noticed that the dialer does not disconnect when I get Event Viewer Message 1 (see above), there is just no internet access for those few seconds.
Sometimes though there is a yellow exclamation on it, then I get Messages 1, 2 and 4 (see above). in this case the dialer disconnects.

I have tried to change the network card, ethernet cable, format and reinstall windows without installing anti virus and without firewall. Problem remains.
Note that I just installed Firewall (Zone Alarm), and since then, the problem is happening every 5 minutes. Before I installed the firewall, the problem was still there! just happened every few hours.
I don't know why the firewall makes this problem happen more often, but the problem also happened after clean OS install and without firewall installed, just less frequent (every few hours not every few minutes).
Also I am using the same system for a few years (recent GPU card change) with same drivers/programs installed (including the firewall). And there wasn't a problem like this with internet access.

I disabled firewall protection (set protection to off), but the problem remains the same (happens every 5 minutes).
I now exit the firewall, and now the problem does not happen every 5 minutes (no DHCP warnings in Event Viewer, I don't notice icon changes to 'Acquiring network address'), But the Lease Expires still remains at 5 minutes after the Lease Obtained. I assume that if I keep the Firewall not running, the problem will still remain, just happen like before, every few hours.
I also wonder why having the firewall on seems to make the problem worse. It seems its not the cause, but is making the problem worse...

So what can cause this. I think I tried the possible causes. Unless there is a problem with ISP or similar.

Thank you.

Edited by catcher1, 03 May 2010 - 07:35 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users