Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Use a desktop wifi card connection as uplink to a wifi router


  • Please log in to reply
11 replies to this topic

#1 guman0v

guman0v

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:06:22 AM

Posted 30 April 2010 - 01:53 PM

Hi,

I was wondering if it's possible to use the internet connection off my desktop pc wireless card as the uplink to a wireless router.

At the moment I am using my desktop wifi card to connect to my neighbors' wifi, with permission of course.
I have a WRT54G router that I would like to use to distribute the wifi further.

Details:

Neighbors' router is 192.168.0.1
My router is 192.168.0.2

The way I see it is if I bridge my wifi and lan on the desktop, and hook up the router via ethernet, it will think of it as being a regular modem.. or is this incorrect?

What I have attempted:

- Create bridge between PC LAN connection and PC WIFI card connection
- Connect ethernet cable from PC LAN to WRT54G router WAN/UPLINK port
--> No luck.

Then I tried the WRT54G router standard LAN port
--> No luck.

Any ideas on what I could be doing wrong?

BC AdBot (Login to Remove)

 


#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:22 AM

Posted 30 April 2010 - 05:12 PM

Do you want your router to also have do DHCP?

When you hooked it up either way, did you surf into your router to see if it had gotten an IP address? The IP address it should get for its WAN is the IP address of your PC 192.168.0.2. You'd want to set your router to a static IP address of 192.168.0.2, subnet mask of 255.255.255.0 and DNS of 4.2.2.2.

Bridge the connection and then try it both ways. Start with it in the WAN port. I have never tried this so I am guessing at the answer.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 guman0v

guman0v
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:06:22 AM

Posted 30 April 2010 - 05:27 PM

Do you want your router to also have do DHCP?


Preferably yes. But if that isn't possible, I'm OK with the neighbors' router handling DHCP.

When you hooked it up either way, did you surf into your router to see if it had gotten an IP address? The IP address it should get for its WAN is the IP address of your PC 192.168.0.2. You'd want to set your router to a static IP address of 192.168.0.2, subnet mask of 255.255.255.0 and DNS of 4.2.2.2.


Yes the router did receive an a WAN IP. It was the same IP that the wifi card gets from the neighbors' router. 192.168.0.12

Ok i will attempt to set the router as a static ip, but I'm not sure what you mean by DNS as 4.2.2.2
Where does this number come from?
So.. when I setup static IP, I see the following fields:
- WAN IP
- Subnet
- Gateway
- Satatic DNS 1-3

So WAN IP should be the ip that the wifi card gets? 192.168.0.12
Subnet 255.255.255.0
and gateway?

--

Thanks for the reply btw :thumbsup:

#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:22 AM

Posted 30 April 2010 - 05:45 PM

As I said, I am guessing at all this on what I think should work lol.

- WAN IP - 192.168.0.25 -
- Subnet - 255.255.255.0
- Gateway - same as your bridged connection if that is 192.168.0.12 then OK
- DNS - just put the IP address of their router. should be 192.168.0.1

With the connections bridged, can you post what you see when you do am ipconfig /all at a command prompt, please?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 guman0v

guman0v
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:06:22 AM

Posted 30 April 2010 - 06:49 PM

As I said, I am guessing at all this on what I think should work lol.

- WAN IP - 192.168.0.25 -
- Subnet - 255.255.255.0
- Gateway - same as your bridged connection if that is 192.168.0.12 then OK
- DNS - just put the IP address of their router. should be 192.168.0.1

With the connections bridged, can you post what you see when you do am ipconfig /all at a command prompt, please?


No luck :/
The gateway of the network bridge is 192.168.0.1 - neighbors' router ip.

Here's the output of ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : g
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Network Bridge:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : MAC Bridge Miniport
   Physical Address. . . . . . . . . : 02-C0-CA-2F-A6-B3
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::6584:1860:5917:6adb%46(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.12(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, April 30, 2010 6:49:39 PM
   Lease Expires . . . . . . . . . . : Friday, April 30, 2010 8:42:03 PM
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 771932362
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-09-E5-84-3F-00-1A-4D-4D-73-21

   DNS Servers . . . . . . . . . . . : 209.18.47.61
									   209.18.47.62
   NetBIOS over Tcpip. . . . . . . . : Enabled


#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:22 AM

Posted 30 April 2010 - 09:25 PM

Try turning off the DHCP in your router, making it just a switch. Plug the Ethernet from your PC into one of the 4 ports and whatever you are trying to get online into another. Reboot whatever it is and see it will get online.

I know I am missing something because I am tired and had people asking me about designing websites all day today so my mind is in HTML mode *shiver*

I'll think of it tomorrow when I am a bit more clear headed =) maybe lol

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 guman0v

guman0v
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:06:22 AM

Posted 01 May 2010 - 03:42 PM

Try turning off the DHCP in your router, making it just a switch. Plug the Ethernet from your PC into one of the 4 ports and whatever you are trying to get online into another. Reboot whatever it is and see it will get online.

I know I am missing something because I am tired and had people asking me about designing websites all day today so my mind is in HTML mode *shiver*

I'll think of it tomorrow when I am a bit more clear headed =) maybe lol



Just tried that, still not working
I've been googling about this for a while now, and came across info on ethernet "crossover" cables. I ordered one, will try using it when it comes in.

#8 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:10:22 AM

Posted 02 May 2010 - 04:39 AM

Try turning off the DHCP in your router, making it just a switch. Plug the Ethernet from your PC into one of the 4 ports and whatever you are trying to get online into another. Reboot whatever it is and see it will get online.

I know I am missing something because I am tired and had people asking me about designing websites all day today so my mind is in HTML mode *shiver*

I'll think of it tomorrow when I am a bit more clear headed =) maybe lol



Just tried that, still not working
I've been googling about this for a while now, and came across info on ethernet "crossover" cables. I ordered one, will try using it when it comes in.


Hi your neighbours router address is 192.168.0.1 there dhcp scope may be something like this you will need to check with your neighbour

Dhcp address start 192.168.0.2

Dhcp address end 192.168.0.150

Connect your desktop pc with wfi card up to your wrt54g router via ethernet cable provided to you with your route to one of the wrt's lan portsr and change your router address to 192.168.0.150 the last address in dhcp scope of your neighbours router. Your neighbour may need to reserve that ip address for the mac address of your wrt54g router.

If there last dhcp address is 192.168.0.254 ask them to change this down if they wouldn't mind to 192.168.0.150 doesn't have to be that address but using that as an example.

On linksys ensure obtain an ip address automatically is selected.

Ensure obtain an DNS server address automatically is selected.

Click on apply or save whichever applies.

Turn on dhcp server on linksys set dhcp scope to this:

Dhcp address start 192.168.0.151

Dhcp address end 192.168.0.170

Click on apply or save whichever applies.

Re-boot router still connected via ethernet cable.

Try and connect to internet.

If successful try wirelessly and if successful set up wireless security and happy surfing.

Hope this helps.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#9 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:10:22 AM

Posted 02 May 2010 - 04:48 AM

Just another quickie ensure that your router and the neighbours router is set five channels apart turn off auto channel on both routers and set one to channel 1 and the other to channel 6 to avoid interference and connections dropping out or not connecting at all.

By the way it is very kind of your neighbour to let you use their internet connection :thumbsup:
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#10 guman0v

guman0v
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:06:22 AM

Posted 03 May 2010 - 06:21 PM

It's working! Thank you!

Here are the numbers I used:

Neighbor's router: 192.168.0.1
Channel 11
His DHCP Scope: 192.168.0.10 through 192.168.0.30

My router: 192.168.0.30 (he did get it reserved for my router MAC)
Connection Type: Automatic DHCP
Channel 6
My DHCP Scope: 192.168.0.50 through 192.168.0.90

Edited by guman0v, 03 May 2010 - 06:22 PM.


#11 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:22 AM

Posted 03 May 2010 - 08:07 PM

Gad you got it working. Sorry I couldn't be of more help, its been a bad week =\

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#12 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:10:22 AM

Posted 04 May 2010 - 12:28 PM

Great mate glad it's sorted :thumbsup:
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users