Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Messenger


  • Please log in to reply
13 replies to this topic

#1 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 26 September 2005 - 08:18 PM

Hello,

Does anyone know the definitive answer as to how to stop the Startup Item msmsgs from starting everytime I boot the computer? I can uncheck it in run>msconfig>startup but it keeps coming back.

C:\Program Files\Messenger\msmsgs.exe /background

I have seen ideas at other places around the internet, but really know one seems to know this one!

I searched through the Tips and Tricks forum and couldn't find an answer either.

Thanks so much
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


BC AdBot (Login to Remove)

 


#2 Leurgy

Leurgy

    Voted most likely


  • Members
  • 3,831 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Collingwood, Ontario, Canada
  • Local time:08:31 AM

Posted 26 September 2005 - 08:42 PM

According to our Startup Database, msmsgs.exe is:

Windows Messenger utility. If you don't use Windows Messenger, this can be annoying. Available via Start -> Programs. Go to Windows Messenger > Tools > Options > Preferences and uncheck "Run this program when Windows starts"

When the only tool you own is a hammer, every problem begins to resemble a nail. Abraham Maslo

**** We use our powers for good, not evil ****

 Trying to remove your data from the web is like trying to remove pee from a swimming pool


#3 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:07:31 AM

Posted 26 September 2005 - 08:45 PM

I hope this is of help... Turn Off Messenger


EDIT Sorry Leurgy I was typing as you were.

Edited by acklan, 26 September 2005 - 08:47 PM.

"2007 & 2008 Windows Shell/User Award"

#4 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 26 September 2005 - 09:22 PM

Ok, thanks Leurgy and acklan,

Messenger is not to be found in Start>All Programs

I did change the file name from Messenger to Messengersucks and that seemed to stop it from starting ( I had to do that in safe mode). But it seemed to me that there had to be a better way.

So, I changed the file name back to Messenger and then it started. I opened it up, like Leurgy said and I did not find the exact selection suggested. Instead I found a similar one "Allow Windows Messenger to run in the background". I unchecked that one and rebooted and voila! Not only did it not start, but the selection is completely gone from run>msconfig>startup.

Thanks so much.

So, where is this startup database you speak of? Because next I want to tackle Quicktime.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#5 red59convt

red59convt

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:08:31 AM

Posted 26 September 2005 - 11:01 PM

Here is how to fix the problem for sure.
Click on control panel, click administrative tools, click on services and then scroll down to messenger.
Highlight messenger and then right click.
Click on stop service,
Close windows and messenger will stop popping up.

#6 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 27 September 2005 - 01:46 AM

Thanks red59convt.

UPDATE:

After 2 hours or so, messenger started back up on it's own. It is not in run>msconfig>startup anymore, and yet it still started.

I rebooted, it did not start up. Not for about an hour or so, and then it started up again on it's own.

Playing nice with this one will not work.

I will try the ideas from red59convt next.

Thanks for all your ideas and help, y'all.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#7 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 27 September 2005 - 01:52 AM

Ok, red59convrt, check this out.

In services as you suggested: Messenger- the status is 'blank', and the startup type is 'disabled'. I highlight Messenger, right click, and the only option available to me is Refresh, Properties, and Help.

Can't turn it off here either, apparently, unless I am missing something, and that is entirely possible.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#8 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 27 September 2005 - 02:12 AM

Ok, one more update:

Apparently when I said that messenger was starting up on it's own, that was not accurate. There was a reason why it was starting, and that reason was that some other program was calling for it. I don't know for sure what programs call for it, but perhaps Outlook or Outlook Express? Anyway, Messenger would not start at bootup, which is good, but it still starts on occasion, when called upon, which is still a nuisence if you ask me.

So, it appears that the two options left available to me ( according to the article that acklan supplied the link to ) is 1) change the name of the Messenger folder, or 2) delete Messenger completly.

I have changed the name of the Messenger folder (in safe mode) to Messengersux. It now does not start when I use Outlook or Outlook Express.

Maybe this is the best way to deal with it? Seems like there would be an easier way, but I guess once you know how to do something, it is pretty easy.

Thanks for all your help. I got the result I wanted, and I learned! Can't ask for more than that!

Edited by Albert Frankenstein, 27 September 2005 - 02:13 AM.

ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#9 Leurgy

Leurgy

    Voted most likely


  • Members
  • 3,831 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Collingwood, Ontario, Canada
  • Local time:08:31 AM

Posted 27 September 2005 - 05:40 AM

So, where is this startup database you speak of? Because next I want to tackle Quicktime.


See Startup Programs at the top of this and most other pages.

Grc.com, a well respected computer security site, has complete information on Windows Messenger Service and a little program called Shoot The Messenger that will shut the service down or re-enable it.

When the only tool you own is a hammer, every problem begins to resemble a nail. Abraham Maslo

**** We use our powers for good, not evil ****

 Trying to remove your data from the web is like trying to remove pee from a swimming pool


#10 Klink

Klink

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Midwest, USA
  • Local time:09:31 AM

Posted 27 September 2005 - 04:39 PM

If you are comfortable working with the registry, this will prevent Messenger from starting.

1. Click on Start, Run.
2. Type REGEDIT and press enter.
3. Click on the pluses (+) next to the following items:
* HKEY_LOCAL_MACHINE
* Software
*Policies
*Microsoft
4. If the folder Messenger is not listed, click on the Edit menu, point to New, click Key and then type Messenger for the name of the new registry key.
5. If the folder Client is not listed under Messenger, click on the Edit menu, point to new, click Key and then type Client for the name of the new registry key.
6. On the Edit Menu, point to New, click DWORD Value, and they type PreventRun for the new DWORD value. Remember all of this is case sensitive.'
7. Right click the PreventRun value that you created, click Modify, type 1 in the
Value data box, and then click OK.
8. Quit Registry Editor. :thumbsup:
Vista Home Premium, SP1
Dell Dimension E510
P4 Duo Core 2.2
2 Gb memory

Avast Anti-virus & Malware 4.8
Threatfire 4.0.0.10
Windows Firewall

#11 Herk

Herk

  • Members
  • 1,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:S.E. Idaho, USA
  • Local time:09:31 AM

Posted 27 September 2005 - 11:44 PM

I think there may be some confusion about Windows Messenger. There's "Messenger" which is the note program used in corporate environments, and "Windows Messenger" which is more like MSN Messenger, and is dumped into all Windows computers. You can open the program, which looks just like MSN Messenger, but runs separately, and change the settings to not start when Windows starts. I understand that if you also use Outlook Express, you may have to disable it in there. Here's more on the subject from another forum:

MS Messenger

I recently downloaded a new version of MSN Messenger and immediately ran into a conflict with the old application, one saying that I had signed into messenger on another computer or something. Start -> Programs -> Windows Messenger opens the old one, which immediately turns off the new one, and up pops a message that I have signed in on another computer.

"Messenger" looks like a gray box with text. "Windows Messenger" looks like MSN Messenger, with the contacts, reply window, etc.

Windows Messenger uses msmsgs.exe and MSN Messenger uses msnmsgr.exe.

I think.

Anyway,
here's an article explaining the difference between the three messengers at "Ask Leo." Follow the text around the adverts. :thumbsup:

#12 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:09:31 AM

Posted 29 September 2005 - 09:54 AM

MY CONCLUSIONS

I tried everything in this thread. And the only thing that keeps Messenger from popping up permanently is changing the name of the Messenger folder.

I tried the registry changes, uninstalling, everthing in this thread! Even the things refered to in MS kb.

Opening up the program and telling it not to start was effective in removing from the Startup list in msconfig.

But then changing the name of the folder did the rest, or else it keeps popping up every once in a while, usually when Outook is opened.

Thanks for all of the ideas!
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#13 Leurgy

Leurgy

    Voted most likely


  • Members
  • 3,831 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Collingwood, Ontario, Canada
  • Local time:08:31 AM

Posted 29 September 2005 - 12:08 PM

In Outlook Express (and probably Outlook) go to Tools>Options and on the General tab uncheck "Automatically log on to Windows Messenger". With that and what else you've done it should be gone.

Edited by Leurgy, 29 September 2005 - 12:09 PM.

When the only tool you own is a hammer, every problem begins to resemble a nail. Abraham Maslo

**** We use our powers for good, not evil ****

 Trying to remove your data from the web is like trying to remove pee from a swimming pool


#14 HappyShiner

HappyShiner

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Local time:08:31 AM

Posted 29 September 2005 - 04:37 PM

Hi there,

This is the simplest way to turn off Messenger:

Open Task Manager (Start - Run - taskmgr.exe)

Go to processes tab and verify "msmsgs.exe" is not running. If it is click on the process and choose "End Process"

Go into your Program Files folder.

Rename the Messenger folder to "MessengerOFF"

If you are unable to rename the folder in this manner then boot to safe mode and make the change.

It sounds like that is what you have done, that is a recognised fix for the problem. I just posted it in case anyone else would benefit.

Note: If you try preventing it via a registry fix, (or doing anything else in the registry for that matter) 'always' back it up first. A tutorial on understanding the registry and how to back it up can be found here:

http://www.computerhope.com/registry.htm

Big Smiles

HS




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users