Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with Winsock Provider catalog- Limited or no connectivity


  • Please log in to reply
2 replies to this topic

#1 jlonecke

jlonecke

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:14 PM

Posted 29 April 2010 - 09:31 AM

Hello all.
One of my Clients is running a Dell Dimension E520 with Windows XP SP3.

Recently, he lost his network connection, and gets the "Windows has detected a problem with the Winsock provider catalog on this computer" message when he runs the network diagnostic tool for XP.

Some things I've tried already:

1. Reboot. (duh)

2. Moved the machine from DHCP to Static - No dice

3. Tried the command line reset that I've found online:

netsh int ip reset
netsh winsock reset

- No dice

4. Downloaded LSPFix, but haven't run it because I don't really know what I'm trying to remove there. Am doing a bit more research on that.

5. Run a Malware scan, didn't help


The machine cannot ping any addresses, and the "Limited or no Connectivity" on the connection hasn't changed no matter what I've done.

Suggestions please? Thank you!

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:14 AM

Posted 29 April 2010 - 11:00 AM

Hi jlokecke ,

Have you tried Window Winsock XP Fix ?

Have a nice day.

#3 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:04:14 PM

Posted 29 April 2010 - 01:28 PM

Hi jlokecke ,

Have you tried Window Winsock XP Fix ?

Have a nice day.



If the above does not work, then I would try refreshing the TCP/IP Networking Stack by going to Dial-Up and Networking, right click on your connection icon select properties, uncheck everything in the box hit apply (noting what was there), then reboot then proceed reinstalling the items in that window.

You can also try upgrading your network card drivers,

If the above doesn't work then I would start to suspect malware.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users