Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless network recognition on HP notebook


  • Please log in to reply
14 replies to this topic

#1 bishboy

bishboy

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 28 April 2010 - 06:46 AM

I have an HP Compaq nx6125 notebook, about 4 years old now. I'm running Windows XP. The wireless function worked absolutely fine until sometime last year, when i started having problems. I've tried reinstalling drivers and restoring the system, without any joy. There are lots of discussions on the web relating to HP and wireless issues similar to mine, but i can't see any consistent thread or clear solution.
My situation is that the laptop will connect fine to two networks, whose details were previously stored as preferred networks. If i try to view wireless networks, however, none are available. So, on the one hand i am connected; on the other it appears that there are no networks in the vicinity. Of course, if i want to connect to any other network than these two (and i will now need to do that because i will be travelling), i cannot "see" them and therefore cannot connect to them.
I have had the problem for a few months, and so have been able to check this in quite a few places. I can never "see" any networks, even when other computers can connect to them; and can always access automatically the two that i have stored.
Because i don't have a difficulty with those two networks (and previously didn't have a difficulty connecting to others), i don't believe that it's a hardware problem. I'm also keen not to disrupt the remaining connectivity that i have - so need to be able to get back to the current situation if i am trying out any changes.
Any ideas for diagnostics or for resolving the problem would be most gratefully received.

BC AdBot (Login to Remove)

 


#2 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:04:07 PM

Posted 28 April 2010 - 11:53 AM

Hi bishboy was you using the windows wireless connection service?

If so please do this click on start>control panel>administrative tasks>services and scroll down to the windows wireless zero configuration and left click on mouse to open. When it is open you may see it is in the stopped state or disabled, there should be a drop down menu with a arrow in the right hand corner click on this and set to automatic and underneath there will be a button that says start click on it to start the service once started click on apply and then click ok. You should be able to view wireless networks then.

Hope this helps.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#3 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 29 April 2010 - 09:48 AM

Thanks for the idea, Mr Darth. However, i checked this out and the service is enabled and running (set to start automatically).
Any other thoughts?

#4 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:04:07 PM

Posted 29 April 2010 - 11:35 AM

Hi ok just one more thing to check regarding the windows service apologies if you have already done this the single monitor on the bottom right hand of the taskbar right click it and click on status>properties>wireless network tab and check there's a tick in the box where it says let windows control my wireless or something like that click apply and then ok.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#5 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 PM

Posted 29 April 2010 - 06:43 PM

If you are connected and windows zero config gives you an error. You are using some other software that came with your HP to manage your wireless connection. Look for it and I am sure the networks are listed there. You have to turn that off OR tell windows zero config to take over before windows will show any wireless networks.

Normally there are 2 icons down by your clock that have to deal with wireless, a computer with "broadcast" lines coming off it indicating you are connected via wireless. The other varies but if you mouse over each icon it will have wireless info pop up, right clicking on that icon should bring up the software.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#6 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 30 April 2010 - 01:03 PM

Hi ok just one more thing to check regarding the windows service apologies if you have already done this the single monitor on the bottom right hand of the taskbar right click it and click on status>properties>wireless network tab and check there's a tick in the box where it says let windows control my wireless or something like that click apply and then ok.

Ok sidious, there's no "status" option on the window when i right-click the connection icon. i just have firewall setting, open network connections, repair and view available wireless networks

#7 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 30 April 2010 - 01:04 PM

If you are connected and windows zero config gives you an error. You are using some other software that came with your HP to manage your wireless connection. Look for it and I am sure the networks are listed there. You have to turn that off OR tell windows zero config to take over before windows will show any wireless networks.

Normally there are 2 icons down by your clock that have to deal with wireless, a computer with "broadcast" lines coming off it indicating you are connected via wireless. The other varies but if you mouse over each icon it will have wireless info pop up, right clicking on that icon should bring up the software.


Thanks, CaveDweller, but i'm not using any other software. I did previously use the HP software but that is now disabled and i don't have any other icon related to the connection. Any other ideas? :thumbsup:

Edited by bishboy, 30 April 2010 - 01:05 PM.


#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 PM

Posted 30 April 2010 - 01:42 PM

If you open your Network Connections, right click on your Wireless connection and click Properties, is there 3 tabs at the top? The middle one should be "Wireless networks", click it and put a check mark in the top box, click OK and reboot your PC. Do they show up now?

If there was already a check mark in it, let us know.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:04:07 PM

Posted 30 April 2010 - 01:45 PM

Hi ok just one more thing to check regarding the windows service apologies if you have already done this the single monitor on the bottom right hand of the taskbar right click it and click on status>properties>wireless network tab and check there's a tick in the box where it says let windows control my wireless or something like that click apply and then ok.

Ok sidious, there's no "status" option on the window when i right-click the connection icon. i just have firewall setting, open network connections, repair and view available wireless networks


Apologies bish go to network connections and right click your wireless connection select properties and then wireless tab and ensure there is a tick in let windows configure my wireless connection.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#10 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 30 April 2010 - 05:29 PM

If you open your Network Connections, right click on your Wireless connection and click Properties, is there 3 tabs at the top? The middle one should be "Wireless networks", click it and put a check mark in the top box, click OK and reboot your PC. Do they show up now?

If there was already a check mark in it, let us know.


Yup. That's already checked, to say "Use windows to configure wireless network settings".

#11 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 30 April 2010 - 05:31 PM

Hi ok just one more thing to check regarding the windows service apologies if you have already done this the single monitor on the bottom right hand of the taskbar right click it and click on status>properties>wireless network tab and check there's a tick in the box where it says let windows control my wireless or something like that click apply and then ok.

Ok sidious, there's no "status" option on the window when i right-click the connection icon. i just have firewall setting, open network connections, repair and view available wireless networks


Apologies bish go to network connections and right click your wireless connection select properties and then wireless tab and ensure there is a tick in let windows configure my wireless connection.


See my reply to CaveDweller just now... it's already ticked.

#12 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 PM

Posted 30 April 2010 - 05:46 PM

Uncheck it, reboot and see what happens.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#13 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 01 May 2010 - 02:46 AM

Uncheck it, reboot and see what happens.

Hi - i'm away for the weekend - will check this out Monday - thanks for helping out.

#14 bishboy

bishboy
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 04 May 2010 - 11:52 AM

Uncheck it, reboot and see what happens.


Well, nothing happens. I can't connect, and the wireless network symbol remains with a red "x" beside it. When i try to view wireless networks, it tells me windows can't configure this connection and tells me to tick the checkbox.

When i then turn the checkbox back on, the interesting thing is that windows immediately pops up a message from the icon, saying "Wireless networks detected: one more more wireless networks arein range; to see the list and connect, click this message". Clicking the message opens the wireless network connection dialogue box, which tells me (as usual) that No wireless networks were found.

#15 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:04:07 PM

Posted 05 May 2010 - 12:27 PM

It wasn't the hp wireless assistant you were referring to was it when you said you had disabled it?

If you were referring to the hp broadband connection service uninstall it and try and connect again.

If this fails assuming that the wzc service says started in the services snap in it should connect i would check that your firewall isn't blocking the wzc program and service.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users