Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WDC external drive & SMART - Quick = Fail, Extended = Pass


  • Please log in to reply
1 reply to this topic

#1 nemoga

nemoga

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina
  • Local time:03:24 AM

Posted 18 April 2010 - 01:13 PM

Hello:

I was here distantly, I finally found some usable solutions in exorcising a malware here. Now for something completely different ...

Hardware: Dell Inspiron 6400/E1505 XP SP3
External Drive: Western Digital My Book
Model Number: WDC WD2500JB-00REA0 Firmware Number: 20.00K20 Capacity: 250.06 GB

Problem:
Background: I tripped over its power and the external drive dropped onto a carpet floor. Knocked the casing out of alignment, but could snap it back without opening it. Nothing rattled or fell out.
Recent prior/ongoing issue - suspect I had a trojan hiding in its system restore. Had found it in Dell by Superantispyware 4.35.1002), but none of the others, was traced back to Xnview 1.97.2 beta: trojan.agent/gen-krpytic Had cleared it once, but reappeared in WDC (G:xnview even though did not initiate any transfer of files, & Dell-system restore). Subsequent scans found trojan in same files, none in G:\ drive, but after incident, it was not detected from scan in Dell but quarantined in previous scan (WDC was not wired at time). Wanted to rescan both just to be sure. Had not transferred anything into the WDC in >2 months.

Evaluation after the tumble:
plugged back into Dell laptop via USB firewire.
Was able to access the directory in the usual time. The hard disk made its usual grinding in populating the directory.
Started SAS scan: laptop was still having recurring trojan.agent in approximate usual time (just over 2 hrs). Switched to WDC, started ok, but soon got hung up on picture files (mostly .jpg & .bmp), particularly in sub-directories of largest single picture file, After 4 hours of scanning (!) just paused--normally this is done in well <30 min. Findings, 3 cookies (I recently reviewed logs - I'm not sure if a log is created if the scan is incomplete). Set up second scan - left it overnight, was still hanging in picture files, and still not finished in AM. No findings.
Set up using Malwarebytes 1.45 updated. Clean in Dell, again got hung up in same pict files 9but different 3rd, 4th, and 5th degree subfolders) and lingered a long time in huge .ppt file as well. No findings, but incomplete for G:\

Decided to defrag, first with Defraggler: able to find, 4% fragmentation, the defrag - after completing only 10% in one hour, cancelled it.
Auslogics defrag - 4%, ran defrag, managed to complete after 3.5 hrs. Recheck - still 4%. However the board did show some rearrangement.

I was opening random MS word .docs in WDC -- all appeared intact. Did not explore other files though. Am reluctant to probe further.

Ran McAfee virusscan- was 95% complete after 3 hours, hung up in WDC (think it was pic files, it never the same subfolder and it would take like 15-30 min per file (usually 200 pics/file). After I pulled firewire, McAfee went through Dell registry for final 5% in ~30 minutes. One finding- in Dell: generic dropper!czp in LavaSoft Ad-Aware \toolbox\LT\processwatch.exe (?possible false + --in quarantine)
Ran SAS again, dedicated to WDC - after 7 hours and still not finished (it was not in pict files), cancelled. No findings.

Today ran Speedfan 4.40 - found C:\ drive, but could not find G:\ drive (WDC) . Did not use any Speedfan tools

The external drive itself does not feel hot.

Now went to WDC site - download and ran DLGDIAG. Findings:

Test Option: QUICK TEST
Model Number: WDC WD2500JB-00REA0
Unit Serial Number: WD-WCANK5777895
Firmware Number: 20.00K20
Capacity: 250.06 GB
SMART Status: FAIL
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 2 did not complete!
Status code = 04 (Unknown failed test element),
Failure Checkpoint = 64 (SMART Attribute Test) SMART self-test did not complete on drive 2!
Test Time: 06:32:54, April 18, 2010

Test Option: EXTENDED TEST
Model Number: WDC WD2500JB-00REA0
Unit Serial Number: WD-WCANK5777895
Firmware Number: 20.00K20
Capacity: 250.06 GB
SMART Status: FAIL
Test Result: PASS
Test Time: 09:12:47, April 18, 2010
(this test ran about 2 1/2 hours)

Meanwhile XP Computer mgmt says: My Book (G:) 232.88 GB FAT32 - Healthy

Internet search for possible solutions: the status code = 04, Failure checkpoint = 64 is unusual and rare. The few matches I found were either in Dutch, German, or Spanish.

I'm not sure, but it seems that its the SMART itself is the primary problem. I'm not convinced (yet) that it's a malware or virus inflicted problem. I've had no dialogue boxes or warnings appear about 'imminent hard drive failure'. Still, I can't finish a virus scan, it didn't defrag, and Speedfan couldn't find it. I have not tried to move files in/out. About 3/4th is duplicated on Dell although several files in the Dell are updated. It's now out of my amateur skill sets

What does the DLGDIAG SMART test results mean in this combination?
What's the next step for diagnostics?
What's are the issues seen presently, and are they repairable? and
What are my continencies?

Thanks for considering this. Not sure what or what next. Not even WDC's forum had anything on this.

BC AdBot (Login to Remove)

 


#2 Memphis T-shirt

Memphis T-shirt

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Location:North of Seattle
  • Local time:12:24 AM

Posted 18 April 2010 - 04:03 PM

A few SWAGs (Scientific Wild-A**ed Guess) here.

1) Without Goog'ing this, IIRC correctly.. this drive may be one of the many external USB drives that are known to fail.

2) Dropping/snagging may have damaged the connections on either data or power to the drive itself, or the power or USB cable on the outside (and sometimes even the wallwart/powerbrick). Sometimes this requires some "extreme eyballing" and/or actually "looking at things with test equipment (oscilloscope, voltmeter, ohmmeter.

3) Actual drive failure, but (except for external USB drives) WD's JB-series drives are (at least IMHO) pretty damned good at taking worse impacts than yours.

Number two is my prime choice here.

All of your symptoms point at "excessive retry" issues. SMART often doesn't properly report this if the problem is external to the drive.

Unless I'm severely misreading it, the WD2500JB is a 3.5" EIDE desktop drive. Try removing it from the "Digital My Book" hoopla (just a "bare drive") and rerun SAS /defrag/SMART tests/etc without the original MyBook trappings, doing one of the following.

First choice-
Temporarily install it in a/your desktop PC. If you don't have a spare EIDE port, temporarily pull the data connector for the optical drive. You may have to reset boot order in BIOS as most Dells (as well as most "brand-names") is set up to try booting off the optical drive first.
This way, you won't be throttled by USB transfer speeds.

Second choice-
Buy or borrow an empty "generic" 3.5" externally-powered USB external housing, and put the WD2500JB in that and re-run the checks/scans.
Borrow-- you'd be surprised at how many of "us geeks" have a couple of these laying around "empty". Bug your techie friends on this one.
Buy-- They don't take up much space, and they are nice to have around for times like this. My first choice for this would be a EIDE 5.25" enclosure with an internal power supply (no brick, just an AC cord). That way, you can "create" a temporary USB optical drive or USB HD drive in a hurry. Add a 2.5">3.5" laptop drive adapter, and you have one part of "my toolbox". (PS, my ext case also has Firewire..)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users