Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft debugging program opening randomly


  • Please log in to reply
4 replies to this topic

#1 TheComedian

TheComedian

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:45 PM

Posted 13 April 2010 - 07:18 PM

I came home from work the other day and discovered I was infected with all sorts of malware and viruses. I downloaded Avast! and after many pre-boot scans I thought I finally destroyed everything. I still get some strange random software issues though that Avast! isnt saying is anything of note.

In particular I've had a generic win32 application crash, and more frequently, microsoft development environment keeps opening and crashing randomly- the file mdm.exe seems to be it but nothing says that its a virus file or anything of the sort.

can someone help me out? im not sure what to think at this point. I'll gladly post whatever logs are needed.

thanks

PS Boopme finds this machine to be clean. I am posting a screenshot of what is going on as well. The original thread is here in case anyone wants to see what was done-

http://www.bleepingcomputer.com/forums/t/308849/help-something-is-wrong-and-i-cant-figure-it-out/

Posted Image

Here is what the latest online scan gave me-

C:\Documents and Settings\Ben\My Documents\rezhacker\AIM 5.5.3595.exe Win32/Adware.WBug.A application deleted - quarantined
C:\Program Files\AIM\Sysfiles\WxBug.EXE Win32/Adware.WBug.A application deleted - quarantined
C:\System Volume Information\_restore{B37680B2-BA0A-4E5D-BF30-83E44C588624}\RP2418\A0145089.EXE Win32/Adware.WBug.A application deleted - quarantined

heres what superantispyware had to say

SUPERAntiSpyware Scan Log
http://www.superantispyware.com

Generated 04/12/2010 at 01:55 AM

Application Version : 4.35.1002

Core Rules Database Version : 4793
Trace Rules Database Version: 2605

Scan type : Complete Scan
Total Scan Time : 06:00:00

Memory items scanned : 240
Memory threats detected : 0
Registry items scanned : 7388
Registry threats detected : 0
File items scanned : 145909
File threats detected : 1

Application.PowerReg Scheduler
C:\PROGRAM FILES\MICROSOFT ANTISPYWARE\QUARANTINE\E89CEEE5-A86D-47FF-9D21-69EA19\87A038D5-8FED-44EF-94CB-334070

I also ran Malwarebyes Anti-Malware but I cannot cut and paste that log as something on the machine blocks me from posting it- it creates a connection reset by peer message. I posted the log in the original post from another computer.

Please help!!

Edited by TheComedian, 13 April 2010 - 07:20 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,873 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:45 PM

Posted 13 April 2010 - 07:58 PM

Hi :thumbsup:.

First thing I suggest...dump any malware items which are quarantined. That eliminates them being found on future scans, confusing system issues.

From what I see, this MS Development error is related to users with Visual Basic installed. Do you have some version of Visual Basic, VB.NET, Visual Studio, etc. installed?

I'm not a coder...but it also appears to me that VB files are part of MS.NET.

If you have MS.NET installed...I would assume that it's damaged.

I would then uninstall it, using Add/Remove Programs...then install NET Framework 3.5, SP1.

Louis

#3 TheComedian

TheComedian
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:45 PM

Posted 14 April 2010 - 08:16 PM

I uninstalled the programs you mentioned. SOMETHING is still trying to force it open. Is it a virus? Boopme said that he/she found the machine to be clean and I needed to come here for more help...


Posted Image

#4 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:04:45 PM

Posted 14 April 2010 - 08:32 PM

You did not say whether or not you are using Visual Basic, VB.NET, Visual Studio, etc...

These may provide some insight if so...

http://support.microsoft.com/kb/841698
http://support.microsoft.com/kb/843414


As for the .NET framework...

We must first clean up your .NET framework installation. Download and run this file. It will remove the .NET framework from your computer so that we can reinstall it later.

After running this cleanup tool, it will ask you to reboot. Please do so.

Next, download and install this file. This will reinstall the .NET framework onto your computer.

After another reboot, download and install this file. This will update the .NET framework to what it should be.

Now see if you still have problems.
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#5 TheComedian

TheComedian
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:45 PM

Posted 16 April 2010 - 06:20 AM

I did what you said to do but the problem is still happening- the program opens randomly with an error message. I dont use VB or anything- im no programmer. I was even getting error messages when the program was uninstalled saying to do "X" i needed to have .net framework installed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users