Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Am I Infected?


  • Please log in to reply
2 replies to this topic

#1 Northpole

Northpole

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:26 AM

Posted 07 April 2010 - 04:54 AM

I am not technically minded and am hoping that either someone can direct me to another forum which has already asked this question, or the problem is an easily answered one. (I did try a search but without success) .

I have a 5 day old computer with Windows 7. The night before last it was inadvertently turned off while still downloading files as part of an auto update/shut down session. I spent most of last night trying to get the computer working properly.

The main problem is that a number of the key strokes dont work or at least only work as commands not the letter intended. When in word I can type the letters SIA with no problem but as soon as I type the letter M the word program minimises. The letter R in any application, in word, or typing in a password etc automatically opens a new menu asking which program I want to Run the file in. The directional arrows no longer move the cursor but the screen sides! etc etc.

Have I inadvertently switched a toggle switch which automatically opens every keyboard based short-cut or is the problem more serious?

I have McAfee trial version loaded and that seemed to have turned some of the protections off. I was able to reload it and it now states the computer if fully protected again. A full scan (which suspiciously took about 90 mins to complete) confirmed no infections etc found.

I also went to the Microsoft website to download the essential downloads suggested. This was partially successful but several essentials show as "failed".

Help please as the machine in its current state is almost unusable.

Thanking you in anticipation.


Northpole

BC AdBot (Login to Remove)

 


#2 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:26 AM

Posted 07 April 2010 - 06:28 AM

Haha....I've had this happen to me before...I was like "What the heck?..." :inlove:

Your Windows Logo Key (WLK) on your keyboard is stuck. Check here for the list of Windows Logo Key keyboard shortcuts (among other keyboard shortcuts), including "WLK + M" for Minimize, "WLK + R" for the Run box, and "WLK + arrow key" for the various Aero Snap features.

Try giving your WLK a tap and see if you still get the keyboard shortcut behavior. If it still sticks, you may have to replace the keyboard. Do you have a built-in keyboard (laptop) or an external keyboard?

The first time this happened to me, I was baffled beyond all belief. :huh: Then I noticed a pattern in the weird things happening when I tried to type (the arrow keys making the windows Snap tipped me off)....gave my Windows Key a tap and all was well again. :crazy:

It was confusing, though, wasn't it? :thumbup2:

:huh: to Bleeping Computer, by the way.

kN
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#3 Northpole

Northpole
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:26 AM

Posted 07 April 2010 - 10:55 AM

keyboardNinja Hi and many thanks. The first thing I'll do when I get home is try as you've suggested. Hope this is the answer as it will be the first time any of my computing problems have been so easy to ascertain and hopefully fix.

Thanks again :huh:

Northpole




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users