Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

VBS:malware-gen


  • Please log in to reply
1 reply to this topic

#1 findbosco

findbosco

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:59 PM

Posted 05 April 2010 - 11:07 AM

After plugging my external hard drive into a friends computer, I appear to have become infected by vbs:malware-gen [according to Avast - which deleted autorun.inf off my usb drive each time I plug the drive into my computer]. Additionally, it adds a few other folders on the external drive, which are listed as applications: Recycled and System Restore Information; it also copied the names of existing folders and created additonal apps, then caused the original folders to become hidden. I've since disabled both AutoPlay and Autorun. Also, turned off System Restore for the external drive and set the Recycle Bin to skip itself and just directly delete files when dealing with the external. Ran ComboFix, which deleted a few files from a temp folder, but nothing major [to my untrained eye].

Additionally, I have an app running that I've not noticed before: 030B6F.exe, coming from this folder:
c:\windows\system32\1893F1, which when I navigate to it shows the folder is 1.47MB in size, but when expand the folder, nothing is visible even though it's set to show hidden files.

OK, I think that's about all I know. I've downloaded HijackThis as well, so I can provide a log of both that and ComboFix at your behest! Thank you for the assistance in advance.

Edited by extremeboy, 05 April 2010 - 12:30 PM.
Moved to AII -no logs posted


BC AdBot (Login to Remove)

 


#2 extremeboy

extremeboy

  • Malware Response Team
  • 12,975 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:59 PM

Posted 05 April 2010 - 12:34 PM

Hello and welcome to BC! :thumbsup:

I moved your topic to this forum since no logs were posted. Please do not post the HJT/Combofix log in this forum/topic/

We are going to prepare you to post a topic in the Malware Removal forum. Please follow the two steps below:

1st Step: Preparation Guide Before Starting a Topic in the Malware Removal Forum: http://www.bleepingcomputer.com/forums/t/34773/preparation-guide-for-use-before-using-malware-removal-tools-and-requesting-help/
2nd Step: Starting a New Topic in the Malware Removal forum: http://www.bleepingcomputer.com/forums/f/22/virus-trojan-spyware-and-malware-removal-logs/

Please reply back here once more once you have started a new topic in that forum and have posted the necessary logs.

Thanks.

With Regards,
Extremeboy
Note: Please do not PM me asking for help, instead please post it in the correct forum requesting for help. Help requests via the PM system will be ignored.

If I'm helping you and I don't reply within 48 hours please feel free to send me a PM.

The help you receive here is always free but if you wish to show your appreciation, you may wish to Posted Image.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users