Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SWF File Not Loading.


  • Please log in to reply
11 replies to this topic

#1 ChapperZHTID

ChapperZHTID

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 03 April 2010 - 07:10 AM

Hello.

I am currently developing a website for a client to do with music. I have created a Flash SWF file, I made the file using Anim-Fx and it works with the provided HTML code, SWF file and the TXT file if I browse on my local computer but as soon as I upload it to the web the file does not seem to be responding. When loading the page a white background appears where the file should be then all goes black.

The Code Which Anim-FX Gave Me Is:
<object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
 codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
 width=580
 height=199>
 <param name=movie value=worldmap.swf>
 <param name=quality value=high>
 <param name=BGCOLOR value=#000000>
 <param name=SCALE value=showall>
 <embed src=worldmap.swf
 quality=high
 pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
 width=580
 height=199
 bgcolor=#000000
 scale= showall>
 </embed>
 </object>

The Code Which I Am Trying Is:
<object width="580" height="199"><param name="movie" value="worldmap.swf" />
 <embed src="[url="view-source:http://www.chapperzdesigns.co.cc/worldmap.swf"]worldmap.swf[/url]" width="580" height="199" /></object>

The Webpage In Question Is:

www.chapperzdesigns.co.cc

The SWF file can be found at:
http://chapperzdesigns.co.cc/worldmap.swf.
I can send the SWF file to you if you need proper access to the file.

The TXT file can be found at:

http://chapperzdesigns.co.cc/worldmap.txt

The text file as you can see does not show the information inside, i believe this is the problem but the text file has got this information
:

"&label600=World Map&constructor=[type  Function]&__proto__=[object Object]&globalsound=[object  Object]&freeze=&url=&urljumpto=&loop=0&loaded=1&effect=600&colorbackground=0x000000&colortext=0x48FE00&line1=Pulse  91.8&line2=The Beat Is Rocking And Theres No Stoping&line3=The  Best In Online Radio&line4=We Are Looking For New DJ's, Enquire  Now&line5=&x1=5&x2=5&x3=5&x4=5&x5=5&y1=150&y2=150&y3=150&y4=150&y5=150&vol=0&s1=300&s2=100&s3=200&s4=100&s5=100&bg=&frameto=_level0.interfaceholder.frameonclick&license=Don't  remove this paragraph, or your template will stop working. Anim-FX owns  the copyright to this template, which may not be sold or resold, in its  original form or as part of another template, by anyone other than  Anim-FX.com. To check the full license restrictions, please refer to [url="http://www.anim-fx.com/license.html.&%22"]http://www.anim-fx.com/license.html.&"[/url][b]
 [/b]


I have looked online but I cant seem to fix myself I have checked to see if HotLink Protection is stoping it working but its disabled.

I would be really grateful if someone could help me resolve this.

I am not making you but if it is a simple fix like wrong code or something I would be grateful if you could share it with me.

All your help is welcome, any questions? Please just ask.

Edited by ChapperZHTID, 03 April 2010 - 07:58 AM.


BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:08:46 AM

Posted 03 April 2010 - 12:21 PM

Is the flash file in the same directory as your web page?

#3 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 03 April 2010 - 12:28 PM

Yes it is. I have even uploaded in Ascii and Binary Mode.

#4 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:08:46 AM

Posted 03 April 2010 - 02:34 PM

The only other thing that I can think of is that perhaps there is a permissions issue. Other than that, it is time to contact your host and see what they have to say.

#5 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 03 April 2010 - 02:38 PM

"Permission Issues" If You Know What Files Should Be On What Permissions I Can Change That. What Would I Need To Ask My Host If It Comes To That?

#6 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:08:46 AM

Posted 03 April 2010 - 02:58 PM

I have no access to your server, and therefore would have no idea what to change. You need to contact your host, explain the problem, and see what they say.

#7 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 04 April 2010 - 11:22 AM

I have just been thinking of something. I am now using SWFObject in order to get the flash working. I use a text file for the flash file to read the information to display, so my thoughts have been what is calling the text file. I don't believe anything is as when I moved the text file outside the folder on my laptop the flash didnt work but when i put it back it worked and like I said when I look at the text file online it has got no information so I believe it wont work as it either cant read the text file or what ever is happening to the text file. If anyone may understand what I am saying I would be grateful for some help.

Thank you in advance

#8 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 04 April 2010 - 05:17 PM

Hello Guys Not Had Much Response But Heres More Information.

I downloaded FireBug for firfox to see if it would help me understand what is wrong. And after taking a look at the log it produced I better understand the problem. The problem is the attached TXT file.

Here is the information i got from the log:

Response Headerspretty printHTTP/1.1 200 OK
Date: Sun, 04 Apr 2010 22:01:30 GMT
Server: Apache
X-Powered-By: PHP/5.2.10
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html

Request Headersview sourceHosterr.000webhost.comUser-AgentMozilla/5.0 (Windows; U;  Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET  CLR 3.5.30729)Accepttext/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8Accept-Languageen-gb,en;q=0.5Accept-Encodinggzip,deflateAccept-CharsetISO-8859-1,utf-8;q=0.7,*;q=0.7Keep-Alive115Connectionkeep-aliveCookiehash=3FAzXejAyMwmCo3r

As you can see it is just coming up with the error at err.000webhost.com

I have made a new URL just to get this working and the files and the site can now be found at www.chapperzwebportal.co.cc

The only file on the page is the flash, please please please please tell me how I can get this txt file working.

#9 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:06:46 AM

Posted 05 April 2010 - 05:56 AM

http://chapperzdesigns.co.cc/worldmap.txt gives me a 404 error. Double check that the filename is correct including letter case. In many systems worldmap.txt is not the same as WoRldMAp.Txt

#10 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 05 April 2010 - 06:51 AM

http://chapperzdesigns.co.cc/worldmap.txt gives me a 404 error. Double check that the filename is correct including letter case. In many systems worldmap.txt is not the same as WoRldMAp.Txt


Thank you for your response. The worldmap.txt is in the server but im geting the 404 error to. I have tryed Binary and Ascii Mode but not working. I really don't know what going on

#11 ChapperZHTID

ChapperZHTID
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Margate
  • Local time:02:46 PM

Posted 05 April 2010 - 10:17 AM

Thank You To All Helping. I Contacted My Host And The Problem Is They Do Support Flash But With The Free Account I Have They Don't Allow .txt Files Which Was The Problem So The Fix Is Me Buying A Account With Them Lol.

Thank All!

[TOPIC CLOSED]

#12 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:06:46 AM

Posted 05 April 2010 - 05:26 PM

Aha, that would do it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users