Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

**msls51.dll stopping XP from loading**


  • Please log in to reply
1 reply to this topic

#1 hoodch

hoodch

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:02 PM

Posted 25 March 2010 - 05:53 AM

OS: Windows XP Professional Service Pack 2

Problem: For the last week or two my PC has been running very slow, especially in regards to "Web Browsing". When browsing the web, the browser was redirecting to other web sites and popping up various advertisements.

Yesterday I decided to run combo fix, with the hopes that this would resolve the problem. After combo fix finished I had to reboot my PC, which is when I was slammed with a rather nasty error.

[PROGRAM] could not find msls51.dll

After clicking ok a dozen or so times the logon screen appears. When logging in the error message appears again for about every exe and service that tries to run. Once the PC finally logs in, there is no taskbar, start bar, icons, etc just a blank screen and a mouse cursor.

Not being a total novice with PCs I managed to load the "Task Manager" by pressing ctrl-Alt-Esc. Task manager does complain about msls51.dll missing, but does load once you click past the error a few times. I can then run apps from here by going to "File>New Task (run)".

Any ideas on how I might fix this problem?

Edited by Pandy, 25 March 2010 - 10:57 AM.
Moved from Virus, Trojan, Spyware, and Malware Removal Logs as no logs are included ~Pandy


BC AdBot (Login to Remove)

 


#2 galaxynoodles

galaxynoodles

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:02 PM

Posted 25 March 2010 - 05:47 PM

I had the same problem today when I turned on my laptop, I kept getting an error box saying something about msls51.dll. I figured out how to get online through the task manager and discovered it was a virus, but couldn't find any file called msls51.dll to delete it.
I think it's fixed now, well my start menu and icons are all back so it seems ok.
What I did was download AVG Free, and as soon as I loaded it, it kept coming up saying there was a problem with the same file called something completely different to msls51.dll, but because it was a system file it couldn't be deleted. So I then downloaded !Killbox, typed in the file address and clicked 'replace on reboot'. Once my laptop had rebooted, I logged in as normal and there were no more error boxes or any problems with my screen.
I don't have loads of experience with computers, so I don't know if this will work for anyone else or whether it'll make the problem worse, so I apologise in advance if it does!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users