Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unresponsive CD/DVD drive after Vista reinstall


  • Please log in to reply
2 replies to this topic

#1 ckimball99

ckimball99

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:22 PM

Posted 24 March 2010 - 12:30 PM

Hi folks. I've found several instances on the forum of others asking basically this same question, but in most cases it does not seem have been resolved, or else the solution was not posted. I've tried a number of the ideas offered but none has worked. Hoping someone has a brainstorm for me.

Recently my Dell Inspiron ground to a halt -- evidently Windows was corrupted, with numerous missing files -- and I eventually had to have it wiped, then have everything reinstalled. (I did not do this myself, not being an expert -- went to a professional.) It seems to be back to normal now, but the CD/DVD drive is completely dead. It's listed in device manager, and any checks I do on it indicate it is "working normally." But when any sort of disc is inserted, nada. I get the slow green bar filling up and when it finally gets to the end, either nothing at all happens, or occasionally the drive ejects and instructs me to "please load a disc," when there is already one there. No error messages.

I ran the Microsoft wizard concerning optical drives. I edited the registry using instructions from a similar post on this site. I opened the CPU and checked that the connections seemed secure. I have thought of trying to update the drivers, but that option button is inactive, and I haven't been able to find the correct drivers on my own through Dell's support site.

Prior to this issue, the drive worked fine and I've burned and played lots of CDs and DVDs. The drive is listed as a TSSTcorp DVD+RW TS-H653F ATA device.

Many thanks in advance for ideas!

BC AdBot (Login to Remove)

 


#2 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:06:22 PM

Posted 24 March 2010 - 01:39 PM

Been through this issue myself, it does seem more probmatic with both Vista and Windows 7.

I do have a suggestion though, it did work for me when I ran into the same issue you're talking about.

I suggest you remove the drive and gain access to the laser's lens.

Use a cotton swab dipped in isopropyl alcohol and gently wipe the lens, becareful not to disrupt the alignment of the lens while doing this!

Once the drive is reinstalled try using it again and see if this resolved your problem.

The problem with optical drives (specially burner drives) is the lasers ware out and become weak over time and have trouble reading certain data tracks or formats.

If you continue having problems with this drive, I suggest you replace it with a new one, drives of this type are so cheap in price these days and not worth the repair cost which is way more then the price of a new drive!
Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#3 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,707 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:22 PM

Posted 24 March 2010 - 07:57 PM

One of these may help:
1. Uninstall the drive through Device Manager.
Restart computer. The drive will be automatically reinstalled.
or...
2. http://support.microsoft.com/kb/314060
Restart computer.
or...
3. Download, and run Restore Missing CD Drive patch
Double click on cdgone.zip to unzip it.
Right click on cdgone.reg, click Merge.
Accept registry merge.
Restart computer.
or...
4. Go to Device Manager, click a "+" sign next to IDE ATA/ATAPI Controllers.
You'll see two items:
- ATA Channel0 (or Primary Channel)
- ATA Channel1 (or Secondary Channel)
Right click on each of them, and click Uninstall. Confirm.
Restart Windows. They'll be automatically reinstalled.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users