Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Harddisk


  • Please log in to reply
4 replies to this topic

#1 carlos6

carlos6

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:03:41 PM

Posted 22 March 2010 - 04:55 PM

I have an 80GB IDE Hitachi HD which was formatted NTFS on my computer running Win 7 Ultimate. My problem is that when connected to my computer via external Sharkoon Drive link USB adapter, it is not shown in Windows Explorer but is shown in Device Manager as USB Device and in Computer Management it is shown as ‘Disk 1 – Not initialized’ and when clicking on to initialize, an error shows as ‘This device not ready’. Same occurred on another PC running Vista Ultimate. Strangely, when connected to IDE inside PC it works perfectly. Can anyone help please?

ASUS P5GC-MX/1333 MB
500GB sata Hitachi HDD
2GB Ram
3.2GB CPU
Windows 7 Ultimate

BC AdBot (Login to Remove)

 


#2 Platypus

Platypus

  • Global Moderator
  • 15,213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:06:41 AM

Posted 22 March 2010 - 05:05 PM

Does the USB adaptor work correctly with any other drive?
Top 5 things that never get done:

1.

#3 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:07:41 PM

Posted 23 March 2010 - 01:46 PM

Does it work with USB on other computers? This could be a driver issue with your USB Drivers.

#4 robinofloxley

robinofloxley

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:08:41 PM

Posted 23 March 2010 - 08:10 PM

My USB Seagate 500Gb playing up last two days.

Keeps coming up USB device malfunctioned or "could not be installed".

(after reboot or restart or wake up from sleep)

It's under my desk, normally hanging off a cheapo USB hub.
Working fine before.

So far, I have found that ejecting/safe remove, pulling the USB plug at the computer, pulling the power lead. Spin down, reconnect power, spin up, reconnect USB and it's fine.

Have tried without the hub, direct into 1 USB port. Not tried the other two yet (I am always having probs with bloody flash cards)

I will investigate when I have more time. But try the cables/power trick.


I used to prefer EASEUS partition manager to Computer Disk Management.

But now with W7, use EASEUS Todo Backup and or Partition Wizard.
Google them and download from your favourite, safe download site and see if they can see/initialize (mark active??) your drive.

That's the limit of my knowledge experience. Good luck.

#5 keveenanderson

keveenanderson

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:41 PM

Posted 24 March 2010 - 01:32 AM

You can check your USB adapter with another harddrive in another computer. If it's not working then problem is in your USB adapter and if harddrive working then you have to update your USB drive from ypur computer and then check it your harddrive and you can also check your USB port.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users