Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Battlefield 2


  • Please log in to reply
11 replies to this topic

#1 snooz

snooz

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:11:13 AM

Posted 11 September 2005 - 02:27 PM

I have BattleFIeld 2 and it always lags on me not like the internet lag but its that my computer aint good enough to run it perfect. I have a GeForce 6200 OC AGP 256MB so i would think that would run fine for it (and i have EVERYTHING on LOW) 512MB RAM. But what im trying to get to is Dose anybody know how to make it run better for me???? like would it help if i deleted stuff or like uninstalled other games???? Please Help.

BC AdBot (Login to Remove)

 


#2 legoman786

legoman786

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, AZ
  • Local time:09:13 AM

Posted 11 September 2005 - 04:12 PM

First, it would be good to clean your system of anyware unknown spyware/malware via HiJack This. Second, try to see if all your internal cables are out of the way, for better cooling. And, finally, do some tweaks with the registry (WARNING: DO NOT MESS WITH YOUR REGISTRY UNLESS YOU KNOW WHAT YOU ARE DOING AND/OR GUIDED BY AN EXPERT)

Edited by legoman786, 11 September 2005 - 04:13 PM.

Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
- Rick Cook


#3 Wizdabest

Wizdabest

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:13 PM

Posted 11 September 2005 - 04:44 PM

I would probably say get another 512 stick of ram.

I've got a P4 2.4 ghz processor, gig of ram, BFG 6800 gt oc 256 agp and I have to turn down some of the graphics and it still lags me a bit when I first enter a server, but not near as much as when the graphics are all the way up.

#4 conk

conk

  • Members
  • 295 posts
  • OFFLINE
  •  
  • Location:midlands
  • Local time:05:13 PM

Posted 11 September 2005 - 04:51 PM

my dad has BF2 on his pc and he only has 128mb graphics and 512 ram and thet runs fine on high mode although it does lag a tiny bit when you 1st enter a server but after like 4 or 5 seconds its fine
If the universe is ever expanding, what are we expanding into?

#5 Wizdabest

Wizdabest

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:13 PM

Posted 11 September 2005 - 05:38 PM

my dad has BF2 on his pc and he only has 128mb graphics and 512 ram and thet runs fine on high mode although it does lag a tiny bit when you 1st enter a server but after like 4 or 5 seconds its fine

for me its a couple minutes. When I have everything on the highest, it'll lag for like 10-15 minutes.

#6 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:11:13 AM

Posted 11 September 2005 - 08:10 PM

If you have lag on a server, it may not be your computer but either the particular game server you use or your internet connexion. Some lag, especially when you first log on, or find yourself in busy areas, is to be expected.
Regards,
John
Whereof one cannot speak, thereof one should be silent.

#7 conk

conk

  • Members
  • 295 posts
  • OFFLINE
  •  
  • Location:midlands
  • Local time:05:13 PM

Posted 12 September 2005 - 12:30 PM

thats the weird thing with my dads it lags on every server but only at the beginning and not in a firefight
If the universe is ever expanding, what are we expanding into?

#8 Wizdabest

Wizdabest

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:13 PM

Posted 12 September 2005 - 01:56 PM

thats the weird thing with my dads it lags on every server but only at the beginning and not in a firefight

yea, thats the same with me. I think its just the graphic settings and how long it takes to render (or whatever) all the effects of the map. When I had all the graphics turned up all the way, it would take 20-30 minutes of unbareable lag until I could actually play. Then when I turned the graphics down a little, it only takes like 3-4 minutes until I can play without much trouble.

#9 conk

conk

  • Members
  • 295 posts
  • OFFLINE
  •  
  • Location:midlands
  • Local time:05:13 PM

Posted 13 September 2005 - 04:38 AM

hmmmmm ill have to try that because its a really good game but the lag makes it unbearable
If the universe is ever expanding, what are we expanding into?

#10 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:11:13 AM

Posted 13 September 2005 - 09:13 AM

Some things you can take a look at to improve performance:
1. Kill any unneeded programs running in the background.
2. Defrag your computer.
Cheers,
John
Whereof one cannot speak, thereof one should be silent.

#11 conk

conk

  • Members
  • 295 posts
  • OFFLINE
  •  
  • Location:midlands
  • Local time:05:13 PM

Posted 13 September 2005 - 09:27 AM

hmmmm a defrags not a bad idea because of the amount of freeware i download thanks igweed
If the universe is ever expanding, what are we expanding into?

#12 Mallen

Mallen

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:12:13 PM

Posted 15 September 2005 - 11:51 PM

Plus don't forget, sometimes your vid card can meet the memory requirements but be a little old anyway. AGP is outdated now, because of PCI Xpress. I doubt that would have a big deal, buy you might wanna check the box and make sure.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users