Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

INTERNET EXPLORER 8 SEARCH PROVIDER CHANGED


  • Please log in to reply
5 replies to this topic

#1 kowski55

kowski55

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:39 AM

Posted 07 March 2010 - 10:49 PM

Greetings. I'm new to this, but here I go. I've been getting a pop-up when I go on the internet. It says, "A program on your computer has corrupted your default search provider setting for Internet Explorer. Internet Explorer has reset this setting to your original search provider, LiveSearch(search. live.com). Internet Explorer will open Search Settings, where you can change this setting or install more search providers."
This started when I started using Vuze. I thought that the Vuze program was the corrupting program. This didn't bother me too much until I got the XP Antivirus 2010. After running Spybot S&D, Avast! 5 scans and Antimalware I think the infection is resolved.
Now the home page won't download. Vuze search won't work and Windows XP search doesn't work nor can I open System Restore.
I'm using Windows XP Home Edition Version 2002, Service Pack 3, Dell Dimension 4700, Pentium 4 CPU.
I've uninstalled Vuze after the infection and reinstalled it and still have the search problems. Any help will greatly be appreciated.
Kowski55

BC AdBot (Login to Remove)

 


#2 StartingOver

StartingOver

  • Members
  • 69 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:About 70 miles from Galveston Bay wade fishing!
  • Local time:03:39 AM

Posted 19 March 2010 - 02:16 AM

Hi Kowski55. Welcome to BC! :trumpet: You've come to the right place. Just be patient because the pro's here are all volunteer and, being one of the best sources on the web for help, they're constantly swamped. But, I promise you it is worth the wait.

In the mean time, maybe this will help better define your problem. I'm guessing your error message looks like this:

Posted Image

The default search provider mentioned in the error message could also be "Bing". In either case, the search provider mentioned will be from our wonderfully arrogant :inlove: big brother, Microsoft. Just another attempt at forcing us to use their bloated, sluggish products.

Then, when you click on the "OK" button (or the red "X" in an attempt to ignore it), you get this next box:

Posted Image

With this screen you have the option of adding more search providers, such as Google, and setting them as your default search provider. If you've tried this, you have already found that the next time you open IE, you get to go back through the same exercise in futility and the default selection you made has been ignored. You'll also notice on this screen that you can delete any search provider in the list EXCEPT the Microsoft search provider (Bing or Live Search).

If you do a Google search for this error, such as "corrupted default search provider settings", you will find thousands of places to get instructions on how to correct the issue. But BEWARE!! Most of the suggestions involve editing your computer's registry. And, just in case you are not familiar with the registry, it is not a place for the inexperienced to venture without detailed guidance. You can easily render your computer completely unresponsive and inoperable. However, with the guidance of one of the pro's here, you can get through it with ease. If you do have some experience with the registry, you might try some of the advice found with a Google search. Just be careful.

Oh yeah, you'll also find the suggestion of resetting IE by going through the control panel. I haven't found anyone that had success with this, though.

The most maddening part of the error you, and the rest of us, are facing is that Microsoft has known about this error for several years. I've found postings dating back to 2007 and, if I'm not mistaken, even 2006. It would seem to me, since Microsoft cares soooo much about it's customers :thumbsup: , it would have issued a patch by now. But all I've found are some convoluted edits you have to make to your registry posted on some of their user forums (and I do thank those users for taking the time to offer their assistance). I can find absolutely nothing about the error on Microsoft.com. It's as if the error didn't exist when you search their site.
I guess, for them it doesn't. It's not their search engines that are being denied. :flowers:

I wish I had better news but, I've been facing this myself for a while. I hate editing my registry but that is where I'm headed when I finish this post. I hope someone here has an easier fix for you.

One last thought. Download Firefox, make it your default browser and KILL IE! :huh: Firefox works better than IE anyway!

Good Luck!
StartingOver

Edited by StartingOver, 19 March 2010 - 02:28 AM.

Just Remember "To Err Is Human" (To REALLY Foul Things Up Requires A Computer!)

#3 kowski55

kowski55
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:39 AM

Posted 22 March 2010 - 05:13 PM

Thanks, StartingOver. I had Safari on my computer and I could use that instead of IE8. I seen an ad on this web site about ReImage and gave them a try. Lo and Behold after they did their thing everything is running fine. They removed IE8, though I liked using that browser I'll get over it.

#4 StartingOver

StartingOver

  • Members
  • 69 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:About 70 miles from Galveston Bay wade fishing!
  • Local time:03:39 AM

Posted 11 April 2010 - 10:51 AM

Sorry for the delay in replying to your last post but, sometimes "life intervenes"!! (There's actually a bumper sticker that says it better "Sh#$ Happens!", but I was trying to clean it up here for the more sensitive viewers!)

In response to removing IE8, I caution against it. (I know this is contrary to my last post but, I was p. o.'d at the entire situation at the time.) I'm sure there are many others who will disagree. But, my first reason for keeping IE8 is Microsoft's updates. I have experienced failed updates if I try to use a browser other that the "great & powerful Wizard's" browser to access their update site. (By the way, IE7 works just as well for Microsoft Updates and doesn't seem to have as many problems.)

My second reason is personal preference. I do like IE8 and, occasionally use it. I also keep it as my default browser. Why? No clue! Just never changed it.

I use Firefox as my main browser. I've never tried Safari. There was a time when I kept seeing articles about Safari having more security weaknesses as compared to Firefox. I don't know if that is true today or not. I haven't researched Safari for some time. Opera was another browser that I heard was good but, like Safari, was reported to have more security risks than Firefox. Again, I've not researched it for some time. Most, if not all of the issue may have been corrected by now.

So, my advice is to either get IE8 cleaned up and working or use IE7 for Microsoft Updates. However, if you are able to keep Windows updated using Safari, then ignore my advice. There is a VERY good chance that I've just never learned how to use a non-MS browser to get my updates.

By the way, I'm also one of those that turns Microsoft's Automatic Updates off completely! I chose to manually review any updates and decide what to download and install and when. I have had one or two occasions where I've installed a "Critical Update for XP" (according to MS) and had conflicts that were difficult to diagnose. Then, after pulling my last few hairs out trying to find the problem, I found that MS knew about the problem for quite a while and had issued a fix which removed the update as unnecessary. (OK. Then why was it "CRITICAL"!) That fix is great for those who already have the problem, but you would think they would have made a correction to the update to stop the rest of us from having to deal with it in the future!!

Sorry for the "soap boxing". My bad for being :thumbsup: !! As you can tell, I'm not Microsoft's biggest fan.

Good luck :flowers: & hope this helps.
StartingOver

Edited by StartingOver, 11 April 2010 - 10:54 AM.

Just Remember "To Err Is Human" (To REALLY Foul Things Up Requires A Computer!)

#5 Cloud Tek Software

Cloud Tek Software

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:39 AM

Posted 15 June 2011 - 08:59 AM

If you have been getting a pop-up when you open Internet Explorer that says, "A program on your computer has corrupted your default search provider setting for Internet Explorer. Internet Explorer has reset this setting to your original search provider, [insert provider here]. Internet Explorer will open Search Settings, where you can change this setting or install more search providers."

We have dealt with this on multiple computers and have decided to try and help everyone that has come across this issue. We offer both a way to fix the program manually or through a utility provided by Cloud Tek Software.


Manual Steps For Correcting Error


Step 1:
Close out of all programs, especially Internet Explorer

Step 2:
Go to Run and type in regedit

Step 3:
Local and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes

Step 4:
Locate and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences

Step 5:
Locate and remove the registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\SearchScopes

Step 6:
Locate and delete the folder RootDrive:\Users\[Your User]\AppData\Roaming\Microsoft\Protect

Step 7:
Exit out of regedit, and restart your computer.


Or, if you do not feel comfortable doing this yourself, you can use the utility provided by Cloud Tek Software. They provide it free of charge, and all they ask is that if helps you that you donate any amount you feel like it was worth. Just download and run the utility and it will make all the necessary changes for you. Be sure to run the utility as an administrator.

Download Utility @ Cloud Tek Software



Originally Posted @ The Squeaky Geek by Cloud Tek Software

#6 invision

invision

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:04:39 AM

Posted 15 June 2011 - 12:38 PM

Better Solution

1. Start, Run, GPEDIT.MSC
2. Expand Computer Configuration
3. Expand Administrative Templates
4. Expand Windows Components
5. Expand Internet Explorer
6. Find Restrict changing the default search provider in the Right Pane. (Right Click-Properties) turn it to Disable.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users