Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Audio Device Driver missing on laptop


  • Please log in to reply
3 replies to this topic

#1 mzberryrican

mzberryrican

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:43 AM

Posted 07 March 2010 - 02:36 AM

So I have this HP DV6629wm laptop that Ive had for a couple years now. The laptop had Windows Vista Home Prem until I upgraded to Window 7 Home Premium in January. Well, recently the audio on my laptop decided to fade out. After awhile it would work again. If I restarted the the laptop it would also work. So I assumed it was something temporary. Well now the audio is not working at all. Now my laptop speaker on the bottom taskbar displays the red cross. Ive checked my Device Manager to see if there was an issue there but the Sound speaker icon was not even there. I did go to HP.com and tried to reinstall the driver update. Which was the sp44700.exe file. Ive tried using the HP Advisor option and tried doing that automatic fix. There I get a yellow triangle with exclamation mark by the information stating that a change was made to the audio driver. Well it doesnt give me much to go by. Ive tried looking online to see if there are other options to fix this issue but I cannot come up with one. I pretty much open for options. I really dont want to take it to a repair guy if its something simple.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:07:43 AM

Posted 07 March 2010 - 12:13 PM

What is sp44700.exe?

This package contains the HP Wireless Assistant for the supported notebook/laptop models and operating systems. The HP Wireless Assistant is a user application that provides a way to control the enablement of individual wireless devices (such as Bluetooth, WLAN, or WWAN devices) and that shows the state of the radios for these wireless devices.


There is no Windows 7 driver
You might try the Vista driver-sp40170.exe
http://h10025.www1.hp.com/ewfrf/wc/softwar...product=3593174
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,486 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:07:43 AM

Posted 07 March 2010 - 03:30 PM

Ive checked my Device Manager to see if there was an issue there but the Sound speaker icon was not even there.


well if your sound hardware is not listed in device manager i would think that the the sound device is no longer working or has a serious problem with it, but i would first try the driver to see if anything happens with that.
sigcomp.png 
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |

#4 mzberryrican

mzberryrican
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:43 AM

Posted 07 March 2010 - 04:32 PM

Ok so up till now this is what is going on. About 2 hours ago I turned on my laptop and the audio came back up. I decided to play a movie file I got on my laptop and let it run for a while. Well I get back on my laptop and decide to look for some information online and the audio again is gone. I had to move my laptop to another room so I did turn it off and back on again. Well the same issue is showing again with the red cross on my audio. It does state "No Audio Output Device Installed". Also the troubleshooting came up and gave me the info "Hardware changes might not have been detected" with the "Detected" in italics afterwards with a yellow triangle exclamation mark inside icon. I had already tried installying that sp40170 before and tried again. I get the error message "Driver Installation Failed: Could not find the device for this driver". So that is what is going on up till now.

I called a family member and his thoughts are either the sound card is messed up and needs replacing or the speakers are faulty but my speakers work fine.

Thanks for the help up till now.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users