Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista, Graphics, and .dll error


  • Please log in to reply
No replies to this topic

#1 yalith

yalith

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 06 March 2010 - 12:17 PM

Hi there and thanks for helping me out.

I am running Windows Vista Ultimate SP1 32-bit on a Dell Inspiron E1505 (laptop) with 2 Gigs of RAM
My video card is an ATI Mobility Raedon X1400.

I had not restarted my computer in a while, so a week ago I decided to restart it. I think I may have left my USB webcam plugged in while restarting, but that's never been a problem before. When my computer restarted, I received this error message:

PCMService.exe entry point not found
The procedure entry point OsThunkD3dContextDestroyAll could not be located in the dynamic link library d3d8thk.dll

I noticed that aero was no longer working and I was back to windows basic. I also noticed that I hadn't done a windows update in a while, so I figured that might be the problem. I did a windows update and still no go. At this point I thought the problem was just with aero.

After searching around on the internet for a little while, I tried some things to get aero to work, like fiddling with the settings, uninstalling my java update and reinstalling it, and running the microsoft tool for problems with aero. It told me there was a problem with my video card driver. I checked my video card, and there were no updates or rollbacks for the driver, and it said it was working fine.

I read somewhere that maybe my windows experience index needed to be refreshed. I went to go do that and it said that New Hardware had been installed and I should refresh my WEI. That seemed weird to me, since I didn't remember installing any new hardware. So I refreshed it. While it was reassessing my WEI, I got an error message.

WinSAT.exe entry point not found
The procedure entry point OsThunkD3dContextDestroyAll could not be located in the dynamic link library d3d8thk.dll

(the same error message I got on starting up the computer)

When the reassessment had finished, it had determined that my graphics ratings (which before had been 3.7) were 1.0 Well at least that explains why aero isn't working.

So, thinking that it might have been a problem with my webcam, I updated my webcam software. No go. My computer knows that the webcam is plugged in, but doesn't get any video from it (The microphone built into the webcam is working though).

So I started getting nervous and tried opening programs that I thought might be related.
As I expected, I'm getting this same error message (the OsThunk... error) when I try to open Windows Photo Gallery or try to use video in skype. When I try to play video in Windows Media Player, it only plays the audio.

I tried to think of things I installed before restarting, but the only things I could think of are Microsoft Silverlight, a Chrome update, and a Flash update.

At that point, the only system restore point I had was from before the windows update, which was after the problem started.

So my conclusion was that something happened to give me this .dll error and that it was causing all of my other problems.

I asked a few of my friends who know things about computers and tried some of the things they suggested.
They thought it sounded like a virus, so I installed Malwarebytes' Anti-Malware and ran it. It came up with a registry key called Rogue.WinAntiVirus, which I had it fix, but it didn't solve the problem. Further scans were clean. My symantec anti-virus has a trojan horse in quarantine called jar_cache39950.tmp and it says that it can't fix it.

Since my computer still had the error messages, I thought that maybe it wasn't just malware related. I tried installing the DirectX Feb 2010 redistributable, and I downloaded the graphics card driver from the dell website and reinstalled it. I got a message that it had installed successfully but with warnings, but I couldn't find the logfile.
None of this solved the problem.

I noticed that a windows update had popped up for my graphics card, which I installed. After I restarted I ended up with an additional issue, which is that the computer starts up, I get the usual error message, and then my display dims. My brightness control still works and says it is at full brightness, but it is dimmer than full brightness usually is (and the way the computer starts up with full brightness). I may be wrong about this, but I think everything has dimmed except the mouse, which is at normal brightness. In fact, at first I thought that my computer was just dimming the way it does when User Account control pops up, but it turned out not to be the case. In any case, the mouse white is brighter than any other white on my display.

So I tried to system restore back to before I installed the Windows update, but the system restore didn't work.
I got this error message:

System restore did not complete successfully. Your computer's system files and settings were not changed.
Details:
The parameter is incorrect: (0x80070057)

When I looked at system restore again, all my restore points were gone.

I uninstalled the most recent windows update (which was just the one for the graphics card). This did not change anything. I then ran the installation for the graphics driver again. This time it completed without warnings, but I am still getting the error messages on startup and when I try to use specific programs, and my display still dims after startup. The dimming happens right after the ATI icon shows up in my taskbar, so I'm guessing it's probably related to whatever is going on with the graphics card.

Basically at this point, I can't tell if all of these problems are the result of some malware, or if it's a hardware/driver problem caused by something else. Either way, I have no idea what to do next, since I've tried all the basic things I can think of. Any help would be greatly appreciated.

Thanks!

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users