Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Limited or No Connectivity


  • Please log in to reply
8 replies to this topic

#1 gszeman

gszeman

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:07:55 AM

Posted 04 March 2010 - 02:14 AM

Hi all,

I recently moved into an apartment and wanted to change my existing unsecured wireless network to a secured network using WPA2 or WPA encryption. The problem is, when I log onto my router and assign WPA2 or WPA encryption, my laptop takes quite a while to connect...but when it does, it says limited or no connectivity. However, when I change it to WEP, or if I disable security it works perfectly...connects right away and the connection is excellent. If anyone has any idea what I can try please feel free. I have already tried restarting the laptop after I configured and restarted the router, I have tried releasing the IP, I have checked the wireless connection properties to make sure they were set up the same (WPA2 PSK, EAS etc.) Nothing has helped other than either disabling the security or using WEP.

The host computer is running:
Windows XP SP3 Gateway Media Center Edition
with a D-Link DL-524 router and a Motorola cable modem.

The laptop is running:
Windows XP SP3 HP Pavilion Media Center Edition

Let me know what other info you may need...again, any help would be greatly appreciated.

Thank you,
Glenn

BC AdBot (Login to Remove)

 


#2 friarduck

friarduck

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pacific Northwest
  • Local time:04:55 AM

Posted 04 March 2010 - 02:27 AM

one of the problems I have had living in an apartment building myself, is interference from other routers and cordless phones. You might want to try another channel setting. Just a thought...
You know you're getting old when the classic rock station doesn't play your classic rock anymore

#3 gszeman

gszeman
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:07:55 AM

Posted 04 March 2010 - 03:34 AM

Thanks for the reply, I just tried different channels and that didn't make a difference...but thanks for the suggestion.

#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:55 AM

Posted 04 March 2010 - 02:13 PM

Below is a list of the different revisions of that router. Which is yours?

* DI-524
* DI-524_REVC
* DI-524_REVD
* DI-524_REVE

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 gszeman

gszeman
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:07:55 AM

Posted 04 March 2010 - 05:02 PM

Thanks for the reply, I believe it is revision C with the current firmware (3.23)

(Edit) Ok...apparently updating the firmware solved the issue...I was using firmware v3.20 and updated to v3.23 and was able to use WPA2 without an issue. Thanks for the replies!

Glenn

Edited by gszeman, 04 March 2010 - 05:07 PM.


#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:55 AM

Posted 04 March 2010 - 05:13 PM

Is this what the wireless page looks like?

When you setup the wireless connection on the PC, are you using WPA2? Because it looks like that router only has WPA. I'm not sure if that is an issue but it might be.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 gszeman

gszeman
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:07:55 AM

Posted 04 March 2010 - 05:16 PM

It's similar, but the security section has a dropdown box with the options, WPA2 and WPA2-PSK are added. I was able to getting it working by upgrading the firmware from 3.2 to 3.23...thank you for your replies...I thought I had upgraded the firmware when I got my laptop last year, but apparently not...or I just did it wrong when I tried last year :thumbsup:

Thanks again!

#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:55 AM

Posted 04 March 2010 - 08:59 PM

So my guess sounded correct. If you set WPA2 up on the PC and WPA on the router it doesn't work. At least it looks that way.

Did the WPA2 show up after you upgraded?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 gszeman

gszeman
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:07:55 AM

Posted 04 March 2010 - 09:09 PM

No, WPA2 was available before that...according to the firmware version 3.20 (the one I was using when it wasn't working), it says WPA2 support was added. The firmware I updated to (3.23), apparently just fixed whatever issue was happening

Firmware 3.20 9/01/2005
Revision Info:
Fixed MAC filtering bug.
Fixed WPA-PSK bug.
Added WPA2 support

Thanks for the replies...I'm just happy that I have some security on it now, so no one else in my building can tap into it!

Edited by gszeman, 04 March 2010 - 09:14 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users