Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

asms file not found after repair install


  • Please log in to reply
1 reply to this topic

#1 Crono139

Crono139

  • Members
  • 70 posts
  • OFFLINE
  •  
  • Local time:07:54 AM

Posted 27 February 2010 - 01:21 PM

My laptop had a Generic Host Process for Win32 Services error upon startup, among other errors. According to MS, the problem only occurs in SP2, but who knows. I ran the repair install with an SP3 disc that I knew worked (not the original, but I have done an install with it before without problems).

The repair worked as it should, and Windows restarted in order to finalize the setup. A message now appears for:

"The file 'asms' on Windows XP Professional Service Pack 3 CD is needed. Type the path where the file is located and then click OK.

Copy files from: GLOBALROOT\DEVICE\CDROM0\I386"

I tried changing the path to D:\I386, but that didn't do the trick. My boot order is currently set to internal HDD, floppy drive, CD drive, and then USB drive.

Thanks in advance.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:07:54 AM

Posted 27 February 2010 - 02:07 PM

the problem only occurs in SP2, but who knows. I ran the repair install with an SP3 disc that I knew worked not the origina



If the hard disk is formatted with the NTFS file system and you are upgrading an earlier version of Windows, use one of the following methods.
Method 1
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

1. When you receive the error message, press SHIFT+F10 to start a command session.
2. Type regedit.exe, and then press ENTER.
3. Click HKEY_LOCAL_MACHINE.
4. On the File menu, click Load Hive, and then load %Windir%\System32\Config\System.sav.
5. When you are prompted to specify a name, type Test.
6. Locate and then click the following key:
HKEY_LOCAL_MACHINE\Test\ControlSet1\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
7. Delete the UPPERFILTERS and LOWERFILTERS registry keys.
8. Repeat steps 6 and 7 for the other ControlSet# keys under the Test hive.
9. Click File, and then click Exit to quit Registry Editor.
10. If the path in the error message is the correct drive letter for the CD-ROM drive, click OK to continue the Setup program.
11. If you receive the error message again, the Setup program cannot correctly read from the CD-ROM drive, or the path information is incorrect. In this case, restart your computer and let the Setup program resume.


Just a thought
I may be out in left field
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users