Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Invalid keyboard code specified


  • Please log in to reply
3 replies to this topic

#1 Bastie

Bastie

  • Members
  • 65 posts
  • OFFLINE
  •  
  • Local time:12:17 AM

Posted 25 February 2010 - 05:21 AM

"Invalid keyboard code specified" has been appearing in the WinMe boot screen recently. The PC runs no worse than before, but I'd like to be rid of that 'mention'. BIOS has no options w.r.t. keyboard which I might edit. What to do ?

BC AdBot (Login to Remove)

 


#2 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:03:17 PM

Posted 25 February 2010 - 01:47 PM

Have a look at this article, if only to check your settings:

http://support.microsoft.com/default.aspx?...B;EN-US;q261417

Similar info off the Internet:

Windows Me: Use Start/Run and enter MSCONFIG.

When the MSCONFIG program opens, go to the International tab.

From the Language dropdown list, select your language and locality (for example, English (British)).

Make sure the MS-DOS Code Page is the number that is correct for your locality (for example, 850 in Western Europe).

Because of a bug in Windows Me, you must also perform the following two steps.

First, in the "Keyboard Data File Name" enter keyboard.sys (for most of Europe);
but do not enter the directory name (e.g. C:\windows\command), only the filename keyboard.sys
even though the two fields above this include the directory name, because a bug in Windows Me
sometimes causes the directory name to be garbled inside the system.

Second, in the "Keyboard Layout" field, you must enter the abbreviation for your country's keyboard layout (for example, uk);
this is often, but not always, the same as the "Language ID" and you must be certain
to use the correct abbreviation for the layout that you need.

Click on OK until you exit MSCONFIG and restart your computer.

[Code pages
437 - United States
850 - Multilingual (Latin I)]

I'm hoping that a WinME user will advise what is correct; long time since I used it.

#3 Bastie

Bastie
  • Topic Starter

  • Members
  • 65 posts
  • OFFLINE
  •  
  • Local time:12:17 AM

Posted 26 February 2010 - 04:18 AM

Have a look at this article, if only to check your settings:

http://support.microsoft.com/default.aspx?...B;EN-US;q261417

Similar info off the Internet:

Windows Me: Use Start/Run and enter MSCONFIG.

When the MSCONFIG program opens, go to the International tab.

From the Language dropdown list, select your language and locality (for example, English (British)).

Make sure the MS-DOS Code Page is the number that is correct for your locality (for example, 850 in Western Europe).

Because of a bug in Windows Me, you must also perform the following two steps.

First, in the "Keyboard Data File Name" enter keyboard.sys (for most of Europe);
but do not enter the directory name (e.g. C:\windows\command), only the filename keyboard.sys
even though the two fields above this include the directory name, because a bug in Windows Me
sometimes causes the directory name to be garbled inside the system.

Second, in the "Keyboard Layout" field, you must enter the abbreviation for your country's keyboard layout (for example, uk);
this is often, but not always, the same as the "Language ID" and you must be certain
to use the correct abbreviation for the layout that you need.

Click on OK until you exit MSCONFIG and restart your computer.

[Code pages
437 - United States
850 - Multilingual (Latin I)]

I'm hoping that a WinME user will advise what is correct; long time since I used it.


The only change I needed to make was to the language ID, and that improved nothing.

Edited by Bastie, 26 February 2010 - 04:29 PM.


#4 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:03:17 PM

Posted 26 February 2010 - 10:33 AM

This needs input from a current WinME user.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users