Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ports WILL NOT open.


  • Please log in to reply
31 replies to this topic

#1 xXAlphaXx

xXAlphaXx

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 23 February 2010 - 05:57 PM

I've been trying too open three ports for hosting a small server. They are unblocked on the router, and the firewall is completely disabled yet the ports are still closed. I ran port probe on these three ports and this is what it comes up with:

Posted Image


I need these ports open ASAP, any help would be appreciated.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

BC AdBot (Login to Remove)

 


#2 Josh3

Josh3

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:08:59 AM

Posted 23 February 2010 - 06:22 PM

Have you checked for all of your firewalls, not just for your router firewall? Like if you have Windows, you are automatically given firewalls and can put the ports in there as well to see if that is your problem or not (Start --> Control Panel --> Windows Firewall/Defender).

#3 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 23 February 2010 - 06:42 PM

All firewalls are disabled.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 23 February 2010 - 08:30 PM

When forwarding ports the 2 biggest mistakes are: 1) Forwarding ports to the wrong IP 2) Not forwarding TCP and/or UDP

On the PC that you are running the server, open a command prompt and type ipconfig and Hit Enter. For your "Ethernet adapter Local Area Connection:" you want the IP address. That is the one to forward to.

As far as the protocols, make sure which you need. Normally you aren't going to get in too much trouble if you do Both but make sure which you need to forward.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 23 February 2010 - 09:47 PM

Checked it again, its on the right computer and everything. :thumbsup:

Still no go.

Ok I've been using PortQryUI, it has now evolved too 'Not Listening'

:flowers:

Edited by xXAlphaXx, 23 February 2010 - 09:48 PM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#6 Orecomm

Orecomm

  • Members
  • 257 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:05:59 AM

Posted 23 February 2010 - 11:34 PM

Do you have a second PC (borrowed laptop, etc.) that you can connect to your local LAN for testing ? If so, try loading NMAP on it and do a scan against your "Port enabled" PC. If it shows the ports open it's time to look carefully at your ISP's rules and regs, or give them a call. Many ISP's restrict "residential" accounts from hosting services, and block ports in their own network to enforce it. Many charge a premium for a "small business" account that can host limited services. You might even get a fixed IP address - for only a moderately absurd fee.

Not Listening, on the other hand, generally means that no process is bound to the defined port. Are you sure the server process is running and trying to listen on those ports ? You can use the Sysinternals TCPVIEW program to see what is going on in pretty good detail.

#7 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 24 February 2010 - 12:06 AM

What is it you are trying to run?

What is the make, model and revision of your router?

Edited by CaveDweller2, 24 February 2010 - 12:33 AM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#8 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 24 February 2010 - 07:27 AM

Its a private sever for Mu Online,

Do you have a second PC (borrowed laptop, etc.) that you can connect to your local LAN for testing ? If so, try loading NMAP on it and do a scan against your "Port enabled" PC.


How exactly would I go about doing this?

I was not running the server at the time that I was checking the ports. My current ISP for this project is Verizon, do you know if they block ports on thier end?

The Router is an old one, Actiontec 704-WG
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#9 Orecomm

Orecomm

  • Members
  • 257 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:05:59 AM

Posted 24 February 2010 - 09:57 AM

OK, the server must be running before the ports will show to be open. You can't listen unless someone has ears.

As for NMAP, it's probably overkill in your case, PortQryUI should be adequate. NMAP is available along with the ZENMAP GUI from NMAP.org, but it may be kind of like trimming your fingernails with a chainsaw in this case, particularly if you have never used it before.

Assuming your Verizon connection is not via the cellular data network (which I don't have experience with and as such cannot comment on) you should be ok as long as you stay in the port range above 1024. The default MuOnline 44405 should be ok.

Edited by Orecomm, 24 February 2010 - 10:31 AM.


#10 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 24 February 2010 - 10:56 AM

You have a FIoS connection from Verizon. I doubt seriously if they are blocking ports.

For Mu Online you need 44405 TCP and 55901 TCP and UDP forwarded.

Oh since you are using an Actiontec 704-WG, its not by IP address its by PC name. So make sure that your PC is the one in the drop down.

Is MuOnline listed in the pre-made ones or did you select User and make a new rule?

I have run countless servers inside my network, using a number of different ISPs and once I made sure I was forwarding to the correct PC and that the correct protocols were being forwarded I've never had an issue.

Oh just out of curiosity, what IP are you giving the people you want to connect to this server?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#11 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 24 February 2010 - 11:53 AM

Ok I will definitly check the port. Yea the correct computer name is selected. I will open up the server and listen too the ports again.

It is listed as a new rule.

I am not home at the moment I will try it later this evening and post the results.

Oh and I'm using my internal ip 111.x.x.x or something like that. I don't remember off the top of my head. But it's not the 192.168... Ip

Edited by xXAlphaXx, 24 February 2010 - 12:21 PM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#12 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 24 February 2010 - 12:43 PM

Yeah, you have to give them your outside IP address. The one from your ISP. The one that shows at the top of this page. Or a better choice is to go here, sign up for an account and make up a URL to give them. Just read the site it'll splain it. Just get a free account.

If you gave them a 192.168.x.x address to connect to, then that is your issue. Because I am guessing more than seeing if the ports are open then simply can't connect to your server.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#13 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 24 February 2010 - 02:50 PM

Nope I gave them my internal ip. I am enroute home at the moment. I will fire up the server and then try out these ports again.

If you don't mind me asking, do you know this off hand? Do you have any experiance with setting up an mu server? Or are you researching this?


Thank you again for the help. I will let you know what happens after I test these ports.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#14 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 24 February 2010 - 03:22 PM

How do I know about ports in general? or the ones for Mu Online specifically? or how to do it in your modem/router? Ports in general - once you learn how to set up a server and the ports needed for it, learning the ports for other programs and setting them up correctly is a snap. Mu Online - I looked it up. Ports in your modem/router - I looked it up too and I have answered a few questions on this forum about that particular piece of hardware.

The biggest thing is giving them your ISP IP. They will never be able to connect to 192.168.x.x.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#15 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:08:59 AM

Posted 24 February 2010 - 03:57 PM

No I gave them the ISP ip, I did not give them the router IP, I am sure of this


After testing the ports again this afternoon, It is now on 'Listening' for 44405 and TCP 55901, however it is not listening for UDP 55901. I checked the router again and the port is listed as open on the router.


Oh and I was asking if you had personal experience with Mu Online because it seems too be such an underground game.


Atleast it sounds like some progress.


EDIT:: Nope! I relized I was trying it on ip 127.0.0.1 (duhhh) Well, I put in Yahoo's Ip address and this is what I got

Port 55901(TCP): FILTERED
Port 55901(UDP): LISTENING or FILTERED
Port 44405(TCP): FILTERED

Edited by xXAlphaXx, 24 February 2010 - 04:05 PM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users