Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to mount C: in Ubuntu


  • Please log in to reply
9 replies to this topic

#1 Dreamchaser_jc

Dreamchaser_jc

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is balmy
  • Local time:04:10 PM

Posted 21 February 2010 - 12:28 AM

Dear all,

I have a problem (http://www.bleepingcomputer.com/forums/t/297179/booting-windows-xp-from-live-cds/?p=1639328) and I have the Ubuntu CDROM which I can use to boot Ubuntu and solve the problem with Windows.

When I get into it, I couldn't seem to open the C:\ because it cannot be mounted. I followed the instruction in the box to type the following in the terminal (bold text):

ubuntu@ubuntu:~$ mount -t ntfs-3g/dev/sda1/media/S3A2004D001 -o
mount: option requires an argument -- o
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
ubuntu@ubuntu:~$ mount -t /dev/sda1/media/S3A2004D001 ntfs-3g force 0 0
mount: only root can do that
ubuntu@ubuntu:~$

And end up still unable to mount the drive. Can someone please guide me? I need to rename the boot.ini file and the giveio.sys file.

Thanks people.

System details:

Win XP Pro SP3
Ubuntu 8.04 LTS
2GB RAM
40GB HD (NTFS)

Edited by Dreamchaser_jc, 21 February 2010 - 12:51 AM.


BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:10 AM

Posted 21 February 2010 - 01:34 AM

What is ntfs-3g?

Should be this:

As root

sudo cd /mnt

sudo mkdir c

sudo mount -t ntfs /dev/sda1 /mnt/c

#3 MadDawg

MadDawg

  • Members
  • 453 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Houston, TX
  • Local time:03:10 AM

Posted 21 February 2010 - 01:52 AM

ubuntu@ubuntu:~$ mount -t /dev/sda1/media/S3A2004D001 ntfs-3g force 0 0
mount: only root can do that


Throw sudo at the beginning of the command and see if it works. It should look as follows:

sudo mount -t /dev/sda1/media/S3A2004D001 ntfs-3g force 0 0

A penguin broke my windows with a half-eaten apple!

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:10 AM

Posted 21 February 2010 - 02:08 AM

What is this ntfs-3g its the first time I have heard of it.

You also need a mount point.

#5 Dreamchaser_jc

Dreamchaser_jc
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is balmy
  • Local time:04:10 PM

Posted 21 February 2010 - 02:18 AM

Hi and Thanks cryptodon. Following what you wrote up there (with ENTER after each line) I get the following:

ubuntu@ubuntu:~$ sudo cd/mnt
sudo: cd/mnt: command not found
ubuntu@ubuntu:~$ sudo mkdir c
ubuntu@ubuntu:~$ sudo mount -t ntfs /dev/sda1 /mnt/c
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda1 /mnt/c -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda1 /mnt/c ntfs-3g force 0 0


And maddawg, adding sudo in front of the line I got back the whole chunk of message I got earlier.

Following CHOICE 2 above, I get the following:

$LogFile indicates unclean shutdown (0, 0)
WARNING: Forced mount, reset $LogFile.
fuse: failed to access mountpoint /mnt/c: No such file or directory

Why can't I force the mount?

Edited by Dreamchaser_jc, 21 February 2010 - 02:22 AM.


#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:10 AM

Posted 21 February 2010 - 02:20 AM

Hi and Thanks cryptodon. Following what you wrote up there (with ENTER after each line) I get the following:

ubuntu@ubuntu:~$ sudo cd /mnt
sudo: cd/mnt: command not found
ubuntu@ubuntu:~$ sudo mkdir c
ubuntu@ubuntu:~$ sudo mount -t ntfs /dev/sda1 /mnt/c
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda1 /mnt/c -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda1 /mnt/c ntfs-3g force 0 0


And maddawg, adding sudo in front of the line I got back the whole chunk of message I got earlier.

Why can't I force the mount?



Is this a LiveCD?

#7 Dreamchaser_jc

Dreamchaser_jc
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is balmy
  • Local time:04:10 PM

Posted 21 February 2010 - 02:23 AM

It's the Ubuntu LiveCD and I boot it from the OS selection menu. Choice 1 is impossible since I have no access to Windows and the optical drive can't read the Recovery DVD (Toshiba).

#8 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:10 AM

Posted 21 February 2010 - 02:25 AM

It's the Ubuntu LiveCD and I boot it from the OS selection menu. Choice 1 is impossible since I have no access to Windows and the optical drive can't read the Recovery DVD (Toshiba).



It should already be mounted check the desktop.

#9 Dreamchaser_jc

Dreamchaser_jc
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is balmy
  • Local time:04:10 PM

Posted 21 February 2010 - 02:28 AM

Yup, it's there! Will go ahead and do what I need to. Thank you very much cryptodon and maddawg.

#10 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:10 AM

Posted 21 February 2010 - 02:34 AM

Yup, it's there! Will go ahead and do what I need to. Thank you very much cryptodon and maddawg.


Glad I could be of assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users