Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Maxtor One Touch - Am I dead?


  • Please log in to reply
1 reply to this topic

#1 Charlie123

Charlie123

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Local time:04:30 AM

Posted 18 February 2010 - 02:19 AM

I dropped a Maxtor one touch external USB drive and when I plug it in, it makes a quiet, intermittent humming sound every three seconds I tried to get three different computers to recognize it but no go. After about ten minutes, I got a ppoup saying the device was ready to use, but it doesn't show up on the drives.

What can I do?

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,723 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:04:30 AM

Posted 18 February 2010 - 09:38 AM

Well...I would remove it from the enclosure...since either the enclosure or the drive itself may be damaged...and try a direct connection of the drive itself to a system.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users