Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sharing internet between wireless iBook and iMac/PC via network cable


  • Please log in to reply
3 replies to this topic

#1 seoliver

seoliver

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 16 February 2010 - 04:57 PM

Hello all!
Hope you can provide me with help on this: A few months ago, I was able to connect my PC and/or my iMac to my iBook via network cable and jump onto the internet from my laptop's Airport connection. I do not recall making any changes to my computer to do that, it just did. Now it doesn't work (I can get on internet with laptop via Airport, but not from PC/iMac hardwired to laptop). Any ideas? :thumbsup:

BC AdBot (Login to Remove)

 


#2 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:06:05 AM

Posted 16 February 2010 - 08:05 PM

On the system that has both a wired and wireless connection go to System Preferences -> Sharing , check Internet Sharing and select Share your connection from: <interface connected to Internet> To computers using: and check the interface (Ethernet or Airport) that the other computers are connected to.

Note that this configuration can give you problems when you move laptops to places like Internet Hotspots as the connection will almost kind of work if it's "backwards". I'd recommend using it only on a desktop machine, but if you do use it on a laptop remember to turn it off (just uncheck Internet Sharing) when you leave home. A better solution is to use a dedicated router.

#3 seoliver

seoliver
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 17 February 2010 - 01:15 PM

On the system that has both a wired and wireless connection go to System Preferences -> Sharing , check Internet Sharing and select Share your connection from: <interface connected to Internet> To computers using: and check the interface (Ethernet or Airport) that the other computers are connected to.

Note that this configuration can give you problems when you move laptops to places like Internet Hotspots as the connection will almost kind of work if it's "backwards". I'd recommend using it only on a desktop machine, but if you do use it on a laptop remember to turn it off (just uncheck Internet Sharing) when you leave home. A better solution is to use a dedicated router.


Hi, thanks for the suggestion. I did try it before I posted, knowing a little about how it "should" work. I have an unconventional setup perhaps in that the modem and wireless router are upstairs out of reach of any network cable, so I was trying to share the Airport connection on my laptop by connecting the two units with network cable to ethernet ports. It worked fine a few months ago, then something happened.

#4 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:06:05 AM

Posted 17 February 2010 - 10:06 PM

It should work as described. On the computer with the wireless connection to the router set your Internet Sharing to share the connection FROM AirPort TO Ethernet, then connect the Ethernet cable from that computer's Ethernet port to the non-wireless computer's Ethernet port. Should work. Several things have changed with sharing and the firewall in recent OSX updates, and it is quite likely that defaults have changed enough to make the process a bit more difficult.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users