Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Not acquiring IP address, cannot access modem page


  • Please log in to reply
4 replies to this topic

#1 HydraHeaded

HydraHeaded

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:23 PM

Posted 15 February 2010 - 09:09 AM

My net connection was down for two days. Today when it started, the icon in the system tray keeps trying to acquire an IP address for a while every time I start the modem, and finally it says that this connection has limited or no connectivity. I can use the internet normally though.

I went to Network Connections and tried the repair option, but nothing happens. In TCP/IP properties, both IP address and DNS servers are set to be obtained automatically, this is how it has been all this time.

When I tried to open 192.168.1.1 in the browser, it doesn't open (in any of the browsers). I did an ipconfig /all, and this is what it shows:

Windows IP configuration:
Host name - XXX
Primary DNS Suffix - nothing
Node type - Unknown
IP Routing Enabled - No
WINS Proxy Enabled - No

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix - nothing
Description - (adapter name)
Physical address - (address)
Dhcp enabled - Yes
Autoconfiguration Enabled - Yes
IP address - 59.95.XXX.XXX (keeps changing since the ISP provides dynamic IPs)
Subnet Mask - 255.255.255.255
Default gateway - same as IP address
DNS Servers - 61.1.96.69 and 218.248.240.208
NetBIOS over Tcpip - disabled

I've reset the modem two to three times today by pressing the reset switch at the back. Finally what I did was enter the IP address and DNS servers manually in the TCP/IP properties. They are:
IP address - 192.168.1.2
Subnet Mask - 255.255.255.0
Default gateway - 192.168.1.1
DNS Servers:
Preferred: 192.168.1.1
Alternate: none

This way I was able to access the modem page, but as soon as I try to set it to obtain the address automatically, the problem starts. So what exactly has gone wrong. Secondly, is it alright to enter the IP address and all manually - does it put you at risk in any way?

Thanks.

BC AdBot (Login to Remove)

 


#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:53 AM

Posted 15 February 2010 - 12:13 PM

What modem do you have? Do you use a separate router?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 HydraHeaded

HydraHeaded
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:23 PM

Posted 15 February 2010 - 09:17 PM

Sorry I don't understand too much about this modem router thing. The only piece of hardware is the Huawei SmartAX MT 882, connected by LAN to the computer.

I've asked others and they say this problem is because DHCP is not enabled in my modem page, but that it is not necessary. But every time I turn on the modem, it starts searching for an IP address (the dots going from one side to another in the little icon in the System Tray), and then it finally says this connection has limited or no connectivity, even though I can use the Internet as usual. I connect by entering the username and password in the Windows dialer, so is it necessary to enable DHCP?

Edited by HydraHeaded, 15 February 2010 - 10:06 PM.


#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:53 AM

Posted 16 February 2010 - 12:26 AM

Your Huawei SmartAX MT 882 is what is called a modem/router. Normally DSL companies do this so you can have one box and still connect multiple computers without the need for a separate router.

To answer your question about DHCP. No you don't have to turn it on as you can tell you can connect to the net just fine. But to access the page you want you'll have to set the IP to what you did.

If DHCP is not turned on inside the modem/router you are going to get the ISP IP address, the 59.95.x.x. If you have that IP address on your PC you aren't going to be able to surf into the modem/router because you aren't in the same network. So when you set the IP to 192.168.1.2 in the PC you put the PC in the same network as the modem/router and could surf in.

To avoid this just turn on DHCP inside the modem/router first then unplug the power from it for a few seconds. While it is settling go back in and set your PC to Obtain IP and DNS auto. The modem/router will give your PC an IP address and you'll be a little more secure because you will be behind the router.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 HydraHeaded

HydraHeaded
  • Topic Starter

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:23 PM

Posted 16 February 2010 - 08:24 AM

I set the IP address in Network Connections > Local Area Connection, accessed the modem page, and enabled the DHCP server, though in the WAN settings type it still reads: Connection Type - Pure Bridged, not DHCP.

Also entered the following settings in the firewall section, which I found from a webpage:
Black List Status - Enabled
Block Duration - 10 minutes
Use Attack Protection, Use DOS Protection - both Allow
Max Tcp Open Handshaking Count - 100
Max ICMP Count - 2
Max Host Count - 2

I've removed the IP address from the Local Area Connection, but now it doesn't search for an IP address; it says: IP address - 192.168.1.2, Subnet Mask - 255.255.255.0, Assigned by DHCP.

Thanks a lot CaveDweller2! :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users