Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Get disconnected from w/l router every 5 min!


  • Please log in to reply
1 reply to this topic

#1 bmvik

bmvik

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:52 AM

Posted 12 February 2010 - 10:24 PM

Hi! I searched and couldnt find a fix for it online. Something is strange going on. We have switched our routers from linksys to ambit brand. Cable company came out and gave us that Ambit... No comments since I like linksys. Anyways we've all had intermitten problems in the house with old linksys router. It was first revision of wrt54g. So i went ahead and flashed it to dd-wrt. that seemed to fix issue for a month. then we started having disconnects again. So we figured the router finally just started going bad.. then it quit. So we got this new one. I have wireless adapter from linksys wusb54gsc first revision. net security is wpa-psk. Every 5 min i have to run ipconfig/release and then renew thru DOS. otherwise i cant browse the web. When i ping google or yahoo - it cant ping. when i ping their IP addresses - i get response. the only way to fix is to release renew. Windows Vista gives me error that it cannot communicate with DNS server 192.168.2.1 NOONE else has the same problem. we have laptops, desktops and an apple pc. I tried another usb card(same exact kind) with same result. If i go to pull up card status to see if i can change DNS servers to say OPENDNS ones, it doesnt even give me that menu. all i can see is that window with Connection and Security tabs (in Control Panel\Manage Wireless Networks). Really wierd... what could be wrong??

i've removed and reinstalled drivers thru Device Manager also.
Wanted to try to fix it without changing WPA PSK mode to WEP... owner doesnt want any changes. Their laptops are older anyways... one even still only supports b and not even g. And it works fine for them.
It drops something to do with DNS (seems like). if i plug in googles ip in address bar it goes to it

i have also tried disabling firewall on my PC and putting my PC's IP in DMZ in the router settings.

I cant change DNS settings in router. Also cant in my pc's wireless card,- i cant get to those settings in my pc. Option simply isnt there to click on. my NIC for the wired connection, for example has those options to change.

BC AdBot (Login to Remove)

 


#2 Orecomm

Orecomm

  • Members
  • 266 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:02:52 AM

Posted 16 February 2010 - 10:03 PM

OK, this is a curious one. I would have thought a problem with a real-time clock messing up key rotations on WPA, but the fact it works with the IP address pretty well debunks that one. So we are looking at a DNS problem that dies every 5 minutes. If you could, check ipconfig \all while it is broken, then do the release and renew and ipconfig \all again. Compare to see what the DNS entries say. Are they the same ? Is it gone entirely when it's broken ? Your DHCP lease lifetime should be much more than 5 minutes, but you might check. Look at the system log too, to see if you somehow got a DHCP Revoke packet in there.

On a side note, are you or have you ever run Norton on this machine ? It has a nasty habit of blacklisting your DNS host under some conditions, but then it shouldn't work at all.

Your DNS settings are set in the Linksys Profile setup, and should be editable there. It's under Manual Setup on the Available Wireless Networks page of the utility. You can try setting the DNS manually and see what happens.

The other nagging possibility is that you picked up a chunk of malware trying to do a DNS hijack that may not have been entirely successful in installing itself but got far enough to bung things up. That eventuality would be better addressed to one of the malware forums, but for now lets check a couple these things out first.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users