Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

x64 vista 32 bit recognition problems


  • Please log in to reply
2 replies to this topic

#1 darkness54

darkness54

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:17 AM

Posted 10 February 2010 - 09:33 PM

I have a windows vista home premium x64, and I have issues playing games that run on x32. I have tried running as administrator and compatability mode, but neither work. When running as an administrator, instead of compatability problems, it then says it can't find it, even though I am looking right at it. Only one of my older games works on it. I have tried all older versions of Doom I have, warcraft I and II, overlord, and even photoshop LD (I can't recall the version). I can run newer games, but those games don't need compatability mode. I had problems on SP1 and now on SP2. Some games after running as an administrator says it installed incorrectly, but after multiple times, I still get the same message. Some just mess up and don't display the error, like the old Doom just looped the sound and showed no part of the game. How new does the game have to be to work on it? They all worked fine on xp, but not on vista. Is there a different solution?

BC AdBot (Login to Remove)

 


#2 the_patriot11

the_patriot11

    High Tech Redneck


  • BC Advisor
  • 6,761 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wyoming USA
  • Local time:08:17 AM

Posted 10 February 2010 - 10:29 PM

unfortunatly, if it doesnt work with compatibility mode it probably just plain wont work. though theres a couple things to try yet-did you isntall them to the x86 program files? sometimes that can make a difference. I guess though if that doesnt work, the only thing I can think of to do to get them to run is dual boot with a 32 bit OS or use something like virtualPC to run a 32 bit version of windows inside of your 64 bit OS. Anyway someone else might have a trick, but thats the only way I can think of to do it, and that would be a lotta work just for a game or 2.

picard5.jpg

 

Primary system: Motherboard: ASUS M4A89GTD PRO/USB3, Processor: AMD Phenom II x4 945, Memory: 16 gigs of Patriot G2 DDR3 1600, Video: AMD Sapphire Nitro R9 380, Storage: 1 WD 500 gig HD, 1 Hitachi 500 gig HD, and Power supply: Coolermaster 750 watt, OS: Windows 10 64 bit. 

Media Center: Motherboard: Gigabyte mp61p-S3, Processor: AMD Athlon 64 x2 6000+, Memory: 6 gigs Patriot DDR2 800, Video: Gigabyte GeForce GT730, Storage: 500 gig Hitachi, PSU: Seasonic M1211 620W full modular, OS: Windows 10.

If I don't reply within 24 hours of your reply, feel free to send me a pm.


#3 Dark Sponge

Dark Sponge

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:17 AM

Posted 16 February 2010 - 07:23 PM

Usually the reason an older game won't work on Vista x64 is because it is a 16bit game. If I remember correctly, the original doom and warcraft are both 16bit games

Unfortunately, while it is possible to run 16bit program in an 64bit environment, Microsoft has not incorporated that functionality directly into Vista.
Other than dual-booting with Windows XP, I've found two solutions that work well:

For Dos 16bit games try downloading and installing D-Fend Reloaded (packaged with Dos Box). It is freeware and relatively easy to setup and use.

For Windows 16bit games you can use Microsoft Virtual PC 2007 (also totally free). Its a bit of a pain to setup. You'll need to create a virtual hard drive and install a copy of windows on it, which means you need to have an old copy of windows laying around to make it work.

I've gotten many of my old games (including Warcraft I) to work inside Vista x64 using these two methods.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users