Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't boot, nvata.sys missing.


  • Please log in to reply
6 replies to this topic

#1 BubbaE

BubbaE

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:19 PM

Posted 01 February 2010 - 11:49 PM

What happened:
I recently ordered a laptop, and when I went to check my email for the tracking number, McAfee and Windows Defender both gave me warnings of infections, McAfee asked me if I wanted to allow registry changes, which I denied. Windows Defender told me it caught a Trojan. I promptly disconnected myself from the internet and scanned with Spybot S&D and it caught several things. Since then I have been doing numerous scans online and off on the computer, different scans caught different things, sometimes trojans, sometimes cookies and adware. During the uninstallation of one of these scanners (AVG) my computer locked up, the uninstall window went white and wouldn't close, and so I tried to close it with task manager, but it wouldn't work. The computer was constantly thinking and being slow, until I pressed the power button once so it would shut down.

Resulting problem:
After trying to boot again, it gave me the error that C:/windows32/nvata.sys (or something along those lines) was missing or corrupted and windows couldn't boot. Since then I have used the Windows XP pro installation CD to try to repair windows, but it didn't work. It makes since it didn't since nvata.sys is an nVidia driver I believe. So far the only recommendation I have gotten was to slave my hard drive to another, access it from the master drive and insert the file. I don't currently have the means or know how to do this (I don't have the file, don't know where to get it, and I don't have a second hard drive that's able to be used at the moment).

Does anyone know of a way I can load windows again without buying a new hard drive, and being able to recover my files?

Thanks.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,753 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:19 PM

Posted 02 February 2010 - 09:35 AM

Depends on what the problem actually is.

Your speculations...are nothing but speculations...regarding what may be a more serious situation than you perceive.

System manufacturer and model?

Since you mention replacing the hard drive...have you run a diagnostic on the hard drive?

Please...post exact wording of any error messages, do not provide cliffnotes versions. The exact wording is very important, since it s the effort by the system to point to a known problem (which may not be the only prolbem and may be merely a symptom of what needs attention).

Louis

Edited by hamluis, 02 February 2010 - 12:32 PM.


#3 BubbaE

BubbaE
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:19 PM

Posted 02 February 2010 - 11:57 AM

When I start, it goes through the booting process, but when it gets to booting the hard drive, this is the error message it gives me:

Windows could not start because the following file is missing
or corrupt:
System32\DRIVERS\nvata.sys

You can attempt to repair this file by starting Windows Setup
using the original Setup-ROM.
Select 'r' at the first screen to start repair.

Like I said, I tried it already, didn't work. I looked up the file, and everything I could find said it was an nVidia driver. That recommendation for slaving the existing drive to a working one is something I found online, and my brother and a friend both recommend doing. Which brings me back to my problem of not having a hard drive I can use at the moment, nor having the knowledge to do it.

My computer is custom built from parts I bought on newegg. It's about two and a half years old and was usually quite reliable. If you need to know part brands and types, I think I find them somewhere.

Edited by BubbaE, 02 February 2010 - 11:59 AM.


#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,753 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:19 PM

Posted 02 February 2010 - 12:31 PM

Can you boot into safe mode?

Louis

#5 Ken-in-West-Seattle

Ken-in-West-Seattle

  • Members
  • 518 posts
  • OFFLINE
  •  
  • Local time:05:19 PM

Posted 02 February 2010 - 01:35 PM

I have a pc on my bench that had that message. It is waiting for a replacement hard drive.
I was able to mount it on a ubuntu live cd and copy the clients files off onto an external drive, but even linux had to skip some files that were in bad sectors. I tried copying 6 different versions of the "missing" file and kept getting the same message.

I hope yours is software, but I have not seen one that could actually be repaired at the console in a long time. This error message seems to me to be one of MS's favorite misleading and hopeful legacy jokes.

Run chkdsk /r from the repair console more than once and see if it will get to "clean". If so you might have a chance with a stage two repair install.

#6 BubbaE

BubbaE
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:07:19 PM

Posted 02 February 2010 - 04:31 PM

No, I can't start in safe mode either.

Ken: I'm not sure how to run chkdsk /r. I tried getting into the recovery console, it made me select which installation I wanted, then gave me the command prompt thing "C:\Windows:" I think it was (I am not able to get to check right this moment). I typed chkdsk, and it asked me to do "/p" or something, but it doesn't recognize the command when I type it in again. Sorry, I'm not familiar with working on computers in this way.

#7 hamluis

hamluis

    Moderator


  • Moderator
  • 55,753 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:19 PM

Posted 02 February 2010 - 04:44 PM

The proper command is chkdsk /r (space between k and /). If there is no space, you get the message you previously received because spacing is important for such commands.

The chkdsk /r command includes all things done by the chkdsk /f command, but it also scans for and attempts to reocover files which may lie in damaged sectors of the hard drive. It's more thorough than chkdsk /f.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users